Skip to content

BarsRepresentation

Canonical path: NemAll_Python_Reinforcement.BarsRepresentation

Bases: ReinfElement, AllplanElement

Implementation of the bar representation element

Label property writable

Get the label

GetBarPlacement

GetBarPlacement() -> BarPlacement

Get the bar placement

Returns:

GetLabel

GetLabel() -> ReinforcementLabel

Get the label

Returns:

GetLabelTextLength

GetLabelTextLength() -> float

Get the text length of the label

Returns:

  • float

    Text length

GetPlacement

GetPlacement() -> BaseElementAdapter

Get the placement

Returns:

GetPlacementLine

GetPlacementLine() -> Line2D

Get the placement angle of the representation

Returns:

GetViewBoundingPolyline

GetViewBoundingPolyline() -> Polyline2D

GetirstRepresentationLine

GetirstRepresentationLine() -> Line2D

Get the represenation line of the first bar

Returns:

SetLabel

SetLabel(label: ReinforcementLabel)

Set the label

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(representation: BarsRepresentation)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string

Placeholder