ReinforcementLabel
Canonical path: NemAll_Python_Reinforcement.ReinforcementLabel
Implementation of the reinforcement label
Methods:
-
GetAdditionalText
–Get the additional text
-
GetAngle
–Get the angle
-
GetDimensionLineOffset
–Get the dimension line offset
-
GetLabelOffset
–Get the label offset for the text pointer
-
GetLabelPoint
–Get the label point
-
GetLabelProperties
–Get the label properties
-
GetPointerProperties
–Get the pointer properties
-
GetPointerStartPoint
–Get the start point of the text pointer
-
GetPositionNumber
–Get the position number
-
GetReinforcementType
–Get the reinforcement type
-
GetShapeSide
–Get the shape side for the text pointer
-
GetShapeSideFactor
–Get the factor for the text pointer at the shape side
-
GetTextProperties
–Get the text properties
-
GetType
–Get the label type
-
GetVisibleBars
–Get the vector with the visible bars
-
IsDimensionLineAtShapeStart
–Get the placement state of the dimension line
-
IsLabelWithComb
–Check for a label with a comb
-
IsLabelWithFan
–Check for a label with a fan
-
IsPointerStartPoint
–Get the state of the start point from the text pointer
-
IsShowAllBars
–Get the show all bars state
-
IsShowTextPointer
–Get the state for showing the text pointer
-
IsShowTextPointerEndSymbol
–Get the state for showing the text pointer end symbol
-
SetAdditionalText
–Set the additional text
-
SetDimensionLineAtShapeStart
–Set the placement state of the dimension line
-
SetDimensionLineOffset
–Set the dimension line offset
-
SetLabelOffset
–Set the label offset
-
SetLabelPoint
–Set the label point
-
SetPointerStartPoint
–Set the start pointer of the text pointer
-
SetShowTextPointer
–Set the state for showing the text pointer
-
SetShowTextPointerEndSymbol
–Set the state for showing the text pointer end symbol
-
SetTextProperties
–Set the text properties
-
SetVisibleBars
–Set the vector with the visible bars
-
ShowAllBars
–Set the all bars inside the dimension line, ... state
-
ToString
–Convert the label data to a string
-
__eq__
–Compare operator
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
AdditionalText
(str
) –Get the additional text
-
DimensionLineAtShapeStart
(bool
) –Get the placement state of the dimension line
-
DimensionLineOffset
(float
) –Get the dimension line offset
-
LabelOffset
(Vector2D
) –Get the label offset for the text pointer
-
LabelPoint
(Point2D
) –Get the label point
-
PointerStartPoint
(Point2D
) –Get the start point of the text pointer
-
ShowTextPointer
(bool
) –Get the state for showing the text pointer
-
ShowTextPointerEndSymbol
(bool
) –Get the state for showing the text pointer end symbol
-
TextProperties
(TextProperties
) –Get the text properties
-
VisibleBars
(list[int] | VecIntList
) –Get the vector with the visible bars
DimensionLineAtShapeStart
property
writable
Get the placement state of the dimension line
PointerStartPoint
property
writable
PointerStartPoint: Point2D
Get the start point of the text pointer
ShowTextPointerEndSymbol
property
writable
Get the state for showing the text pointer end symbol
VisibleBars
property
writable
VisibleBars: list[int] | VecIntList
Get the vector with the visible bars
GetDimensionLineOffset
Get the dimension line offset
Returns:
-
float
–Dimension line offset
GetLabelOffset
GetLabelOffset() -> Vector2D
Get the label offset for the text pointer
Returns:
-
Vector2D
–Label offset for the text pointer from the shape side
GetLabelProperties
GetLabelProperties() -> ReinforcementLabelProperties
GetPointerProperties
GetPointerProperties() -> ReinforcementLabelPointerProperties
GetPointerStartPoint
GetPointerStartPoint() -> Point2D
GetReinforcementType
GetReinforcementType() -> ReinforcementType
GetShapeSide
Get the shape side for the text pointer
Returns:
-
int
–Shape side for the text pointer
GetShapeSideFactor
Get the factor for the text pointer at the shape side
Returns:
-
float
–Factor for the text pointer at the shape side
GetTextProperties
GetTextProperties() -> TextProperties
GetVisibleBars
GetVisibleBars() -> list[int] | VecIntList
IsDimensionLineAtShapeStart
Get the placement state of the dimension line
Returns:
-
bool
–Placement of the dimension line as placemen start state
IsLabelWithComb
Check for a label with a comb
Returns:
-
bool
–Label with a comb: true/false
IsLabelWithFan
Check for a label with a fan
Returns:
-
bool
–Label with a fan: true/false
IsPointerStartPoint
Get the state of the start point from the text pointer
Returns:
-
bool
–Defined start point exist: true/false
IsShowAllBars
Get the show all bars state
Returns:
-
bool
–Show all bars inside the dimension lines, ...
IsShowTextPointer
Get the state for showing the text pointer
Returns:
-
bool
–Show the text pointer: true/false
IsShowTextPointerEndSymbol
Get the state for showing the text pointer end symbol
Returns:
-
bool
–Show the text pointer end symbol: true/false
SetAdditionalText
Set the additional text
Parameters:
-
additionalText
(str
) –Additional text
SetDimensionLineAtShapeStart
Set the placement state of the dimension line
Returns:
-
–
Placement of the dimension line as placemen start state
SetDimensionLineOffset
Set the dimension line offset
Returns:
-
–
Dimension line offset
SetLabelOffset
SetLabelOffset(labelOffset: Vector2D)
SetLabelPoint
SetLabelPoint(labelPoint: Point2D)
SetPointerStartPoint
SetPointerStartPoint(pointerStartPoint: Point2D)
Set the start pointer of the text pointer
Parameters:
-
pointerStartPoint
(Point2D
) –Start point of the text pointer
SetShowTextPointer
Set the state for showing the text pointer
Parameters:
-
showTextPointer
(bool
) –Show the text pointer: true/false
SetShowTextPointerEndSymbol
Set the state for showing the text pointer end symbol
Parameters:
-
showTextPointerEndSymbol
(bool
) –Show the text pointer end symbol: true/false
SetTextProperties
SetTextProperties(textProperties: TextProperties)
SetVisibleBars
SetVisibleBars(visibleBars: list[int] | VecIntList)
Set the vector with the visible bars
Parameters:
-
visibleBars
(list[int] | VecIntList
) –Vector with the visible bars: 1, 2, 3, .. index from left; -1, -2, -3, ... index from right, 0 = center
ShowAllBars
Set the all bars inside the dimension line, ... state
Parameters:
-
bShowAllBars
(bool
) –Show all bars in the dimension lines, ...: true/false
ToString
Convert the label data to a string
Returns:
-
str
–String from the label data
__eq__
__eq__(label: ReinforcementLabel) -> bool
Compare operator
Parameters:
-
label
(ReinforcementLabel
) –Labels to compare
Returns:
-
bool
–Labels are equal: true/false
__init__
overloaded
Initialize
__init__(
reinforcementType: ReinforcementType,
type: LabelType,
positionNumber: int,
labelProp: ReinforcementLabelProperties,
labelPoint: Point2D,
angle: Angle,
)
Constructor
Parameters:
-
reinforcementType
(ReinforcementType
) –Reinforcement type
-
type
(LabelType
) –Label type
-
positionNumber
(int
) –Position number
-
labelProp
(ReinforcementLabelProperties
) –Label properties
-
labelPoint
(Point2D
) –Label placement point
-
angle
(Angle
) –Angle
__init__(
reinforcementType: ReinforcementType,
type: LabelType,
positionNumber: int,
labelProp: ReinforcementLabelProperties,
shapeSide: int,
shapeSideFactor: float,
labelOffset: Vector2D,
angle: Angle,
)
Constructor
Parameters:
-
reinforcementType
(ReinforcementType
) –Reinforcement type
-
type
(LabelType
) –Label type
-
positionNumber
(int
) –Position number
-
labelProp
(ReinforcementLabelProperties
) –Label properties
-
shapeSide
(int
) –Shape side for the text pointer
-
shapeSideFactor
(float
) –Factor for the text pointer at the shape side
-
labelOffset
(Vector2D
) –Label offset for the text pointer from the shape side
-
angle
(Angle
) –Angle
__init__(
reinforcementType: ReinforcementType,
type: LabelType,
positionNumber: int,
labelProp: ReinforcementLabelProperties,
bDimLineAtShapeStart: bool,
dimLineOffset: float,
)
Constructor
Parameters:
-
reinforcementType
(ReinforcementType
) –Reinforcement type
-
type
(LabelType
) –Label type
-
positionNumber
(int
) –Position number
-
labelProp
(ReinforcementLabelProperties
) –Label properties
-
bDimLineAtShapeStart
(bool
) –Placement of the dimension line: at shape start = true / at shape end = false
-
dimLineOffset
(float
) –Offset of the dimension line from the placement
__init__(
reinforcementType: ReinforcementType,
type: LabelType,
positionNumber: int,
labelProp: ReinforcementLabelProperties,
pointerProp: ReinforcementLabelPointerProperties,
bDimLineAtShapeStart: bool,
dimLineOffset: float,
)
Constructor
Parameters:
-
reinforcementType
(ReinforcementType
) –Reinforcement type
-
type
(LabelType
) –Label type
-
positionNumber
(int
) –Position number
-
labelProp
(ReinforcementLabelProperties
) –Label properties
-
pointerProp
(ReinforcementLabelPointerProperties
) –Pointer properties
-
bDimLineAtShapeStart
(bool
) –Placement of the dimension line: at shape start = true / at shape end = false
-
dimLineOffset
(float
) –Offset of the dimension line from the placement
__init__(element: ReinforcementLabel)