ReinforcementSettings
Canonical path: NemAll_Python_Reinforcement.ReinforcementSettings
Implementation of Reinforcement settings
Methods:
-
CheckBarDiameter
–Check, whether the diameter is included in the diameter list of the current steel grade
-
CheckMeshGroup
–Check, whether the mesh group is included in the group list
-
GetBarDiameter
–Get the current bar diameter
-
GetBarFactorForDiameter
–Get Factor for Diameter
-
GetBarWeight
–Get the weight for a bar diameter
-
GetBendingRoller
–Get the current bending roller
-
GetConcreteGrade
–Get the current concrete grade
-
GetConcreteGradesForNorm
–Get the concrete grades for norm
-
GetEngCatCrossSections
–Get the cross sections from engineering catalog
-
GetEngCatDiameters
–Get the diameters for cross section
-
GetEngCatMeshGroups
–Get the mesh groups from engineering catalog
-
GetEngCatMeshes
–Get the meshes for cross section
-
GetEngCatSteels
–Get the steels from engineering catalog
-
GetMaxBarLength
–Get the maximal bar length
-
GetMeshCutOffPlacementLimit
–Get the limit
-
GetMeshGroup
–Get the current mesh group
-
GetMeshType
–Get the current mesh type
-
GetNorm
–Get the current norm
-
GetNorms
–Get the Reinforcement norms
-
GetSteelGrade
–Get the current steel grade
-
Is3DReinforcement
–Get the 3D-Reinforcement state
-
__init__
–Initialize
CheckBarDiameter
staticmethod
Check, whether the diameter is included in the diameter list of the current steel grade
Returns:
-
float
–Bar diameter (original or nearest value)
CheckMeshGroup
staticmethod
Check, whether the mesh group is included in the group list
Returns:
-
int
–Mesh group (original or first)
GetBarDiameter
staticmethod
Get the current bar diameter
Returns:
-
float
–Bar diameter
GetBarFactorForDiameter
staticmethod
GetBarWeight
staticmethod
Get the weight for a bar diameter
Parameters:
-
steelGrade
(int
) –Steel grade
-
barDiameter
(float
) –Bar diameter
Returns:
-
float
–Weight for a bar diameter
GetBendingRoller
staticmethod
Get the current bending roller
Returns:
-
float
–Bending roller
GetConcreteGrade
staticmethod
Get the current concrete grade
Returns:
-
int
–Concrete grade
GetConcreteGradesForNorm
staticmethod
GetConcreteGradesForNorm(NormID: int) -> list[tuple[int, str]]
Get the concrete grades for norm
Parameters:
-
NormID
(int
) –Norm ID
Returns:
-
list[tuple[int, str]]
–List with the concrete grades for Norm as tuple[ID, Name]
GetEngCatCrossSections
staticmethod
GetEngCatCrossSections() -> list[EngCatCrossSection]
Get the cross sections from engineering catalog
Returns:
-
list[EngCatCrossSection]
–List with the cross sections
GetEngCatDiameters
staticmethod
GetEngCatDiameters(EngCatSteel: EngCatSteel) -> list[EngCatDiameter]
GetEngCatMeshGroups
staticmethod
GetEngCatMeshGroups() -> list[EngCatMeshGroup]
Get the mesh groups from engineering catalog
Returns:
-
list[EngCatMeshGroup]
–List with the mesh groups
GetEngCatMeshes
staticmethod
GetEngCatMeshes(EngCatMeshGroup: EngCatMeshGroup) -> list[EngCatMesh]
GetEngCatSteels
staticmethod
GetEngCatSteels() -> list[EngCatSteel]
GetMaxBarLength
staticmethod
Get the maximal bar length
Returns:
-
float
–Maximal bar length
GetMeshCutOffPlacementLimit
staticmethod
GetMeshGroup
staticmethod
Get the current mesh group
Returns:
-
int
–Mesh group
GetNorms
staticmethod
GetNorms() -> list[tuple[int, str]]
Get the Reinforcement norms
Returns:
-
list[tuple[int, str]]
–List with the Reinforcement norms as tuple[ID, Name]
GetSteelGrade
staticmethod
Get the current steel grade
Returns:
-
int
–Steel grade
Is3DReinforcement
staticmethod
Get the 3D-Reinforcement state
Returns:
-
bool
–Create 3D-Reinforcement: true/false