Skip to content

SpiralElement

Canonical path: NemAll_Python_Reinforcement.SpiralElement

Bases: ReinfElement, AllplanElement

Implementation of the bar placement element

ConcreteCoverContour property writable

ConcreteCoverContour: float

Get the concrete cover from the contour

ConcreteCoverEnd property writable

ConcreteCoverEnd: float

Get the concrete cover from the end

ConcreteCoverStart property writable

ConcreteCoverStart: float

Get the concrete cover from the start

ContourPoints property writable

ContourPoints: Polyline3D

Get the contour points

Diameter property writable

Diameter: float

Get the diameter

HookAngleEnd property writable

HookAngleEnd: float

Get the hook angle at the end

HookAngleStart property writable

HookAngleStart: float

Get the hook angle at the start

HookLengthEnd property writable

HookLengthEnd: float

Get the hook length at the end

HookLengthStart property writable

HookLengthStart: float

Get the hook length at the start

LengthFactor property writable

LengthFactor: float

Get the length factor

NumberLoopsEnd property writable

NumberLoopsEnd: int

Get the loops at the end

NumberLoopsStart property writable

NumberLoopsStart: int

Get the loops at the start

Pitch property writable

Pitch: float

Get the pitch

PlacePerLinearMeter property writable

PlacePerLinearMeter: bool

Get the place per linear meter state

RotationAxis property writable

RotationAxis: Line3D

Get the rotation axis

SteelGrade property writable

SteelGrade: int

Get the steel grade

GetLengthSections

GetLengthSections() -> VecDoubleList

Get the length for the sections

Returns:

GetPitchSections

GetPitchSections() -> VecDoubleList

Get the pitch for the sections

Returns:

SetLengthFactor

SetLengthFactor(lengthFactor: float)

Set the length factor

Parameters:

  • lengthFactor (float) –

    Length factor

SetNumberLoopsEnd

SetNumberLoopsEnd(numberLoopsEnd: int)

Set the loops at the end

SetNumberLoopsStart

SetNumberLoopsStart(numberLoopsStart: int)

Set the loops at the start

SetPitchSections

SetPitchSections(
    pitch1: float,
    length1: float,
    pitch2: float,
    length2: float,
    pitch3: float,
    length3: float,
    pitch4: float,
    length4: float,
)

Set the pitch section

Parameters:

  • pitch1 (float) –

    Pitch section 1

  • length1 (float) –

    Length section 1

  • pitch2 (float) –

    Pitch section 2

  • length2 (float) –

    Length section 2

  • pitch3 (float) –

    Pitch section 3

  • length3 (float) –

    Length section 3

  • pitch4 (float) –

    Pitch section 4

  • length4 (float) –

    Length section 4

SetPlacePerLinearMeter

SetPlacePerLinearMeter(bPlacePerLinearMeter: bool)

Set the place per linear meter state

Parameters:

  • bPlacePerLinearMeter (bool) –

    Place per linear meter: true/false

__init__ overloaded

__init__()

Initialize

__init__(
    positionNumber: int,
    diameter: float,
    steelGrade: int,
    concreteGrade: int,
    rotationAxis: Line3D,
    contourPoints: Polyline3D,
    pitch: float,
    hookLengthStart: float,
    hookAngleStart: float,
    hookLengthEnd: float,
    hookAngleEnd: float,
    concreteCoverStart: float,
    concreteCoverEnd: float,
    concreteCoverContour: float,
)

Constructor

Parameters:

  • positionNumber (int) –

    Position number

  • diameter (float) –

    Diameter

  • steelGrade (int) –

    Steel grade

  • concreteGrade (int) –

    Concrete grade

  • rotationAxis (Line3D) –

    Rotation axis

  • contourPoints (Polyline3D) –

    Contour points

  • pitch (float) –

    Pitch

  • hookLengthStart (float) –

    Hook length at the start

  • hookAngleStart (float) –

    Hook angle at the start

  • hookLengthEnd (float) –

    Hook length at the end

  • hookAngleEnd (float) –

    Hook angle at the end

  • concreteCoverStart (float) –

    Concrete cover at the start

  • concreteCoverEnd (float) –

    Concrete cover at the end

  • concreteCoverContour (float) –

    Concrete cover of the contour

__init__(param: SpiralElement)

Args: param

__repr__

__repr__() -> str

Convert to string

Placeholder