class PreviewSymbolBuilder¶
- class NemAll_Python_IFW_Input.PreviewSymbolBuilder¶
Implementation of the preview symbol builder
- ArrowSymbol(...)¶
- ArrowSymbol(pnt: Point3D, bDrawIso: bool, viewProj: ViewWorldProjection, colorVariant: ARGB, widthVariant: int, rotationAngle: float, allWindows: bool = True]) None ¶
Create an arrow symbol
- Args:
pnt:            Arrowhead point
bDrawIso:       Draw the arrow symbol inside the isometric view: true/false
viewProj:       View world projection data
colorVariant:   Color of the preview
widthVariant:   Width of the symbol
rotationAngle:  Rotation angle of the rectangle
allWindows:     Show symbol in all windows
- ArrowSymbol(pnt: Point3D, bDrawIso: bool, viewProj: ViewWorldProjection, colorVariant: ARGB, rotationAngle: float, allWindows: bool = True]) None ¶
Create a small arrow symbol
- Args:
pnt:            Arrowhead point
bDrawIso:       Draw the arrow symbol inside the isometric view: true/false
viewProj:       View world projection data
colorVariant:   Color of the preview
rotationAngle:  Rotation angle of the rectangle
allWindows:     Show symbol in all windows
- Circle3DSymbol(refPnt: Point3D, circle: Arc3D, viewProj: ViewWorldProjection, colorVariant: ARGB, linePattern: int, lineWidth: float) None ¶
Create a 3D circle symbol preview
- Args:
refPnt:        Reference point
circle:        3D circle
viewProj:      View world projection data
colorVariant:  Color of the preview
linePattern:   Line pattern
lineWidth:     Width of the line
- CircleSymbol(pnt: Point3D, bDrawIso: bool, viewProj: ViewWorldProjection, colorVariant: ARGB, radius: int) None ¶
Create a circle symbol
- Args:
pnt:           Center point
bDrawIso:      Draw the circle symbol inside the isometric view: true/false
viewProj:      View world projection data
colorVariant:  Color of the preview
radius:        Radius of the circle in pixel
- CoordCrossSymbol(...)¶
- CoordCrossSymbol(plane: Plane3D, armLength: int, viewProj: ViewWorldProjection) None ¶
Draw the coordinate cross symbol
- Args:
plane:      Plane
armLength:  Length of the symbol arms
viewProj:   View world projection
- CoordCrossSymbol(axisPlacement: AxisPlacement3D, armLength: int, viewProj: ViewWorldProjection) None ¶
Draw the coordinate cross symbol
- Args:
axisPlacement:  Axis placement
armLength:      Length of the symbol arms
viewProj:       View world projection
- CrossSymbol(pnt: Point3D, bDrawIso: bool, viewProj: ViewWorldProjection, colorVariant: ARGB, widthVariant: int) None ¶
Create a cross symbol
- Args:
pnt:           Cross center point
bDrawIso:      Draw the cross symbol inside the isometric view: true/false
viewProj:      View world projection data
colorVariant:  Color of the preview
widthVariant:  Width of the symbol
- FilledRectangleSymbol(pnt: Point3D, bDrawIso: bool, viewProj: ViewWorldProjection, colorVariant: ARGB, widthVariant: int, rotationAngle: float) None ¶
Create a filled rectangle symbol
- Args:
pnt:            Rectangle center point
bDrawIso:       Draw the rectangle symbol inside the isometric view: true/false
viewProj:       View world projection data
colorVariant:   Color of the preview
widthVariant:   Width of the symbol
rotationAngle:  Rotation angle of the rectangle
- Line3DSymbol(refPnt: Point3D, line: Line3D, viewProj: ViewWorldProjection, colorVariant: ARGB, linePattern: int, lineWidth: int) None ¶
Create a 3D line symbol preview
- Args:
refPnt:        Reference point
line:          3D line
viewProj:      View world projection data
colorVariant:  Color of the preview
linePattern:   Line pattern
lineWidth:     Line width
- MarkSymbol(pnt: Point3D, bDrawIso: bool, viewProj: ViewWorldProjection, colorVariant: ARGB, widthVariant: int) None ¶
Create a mark symbol (drawn an x)
- Args:
pnt:           Mark center point
bDrawIso:      Draw the mark symbol inside the isometric view: true/false
viewProj:      View world projection data
colorVariant:  Color of the preview
widthVariant:  Width of the symbol
- OffsetPointSymbols(refPnt: Point3D, offPnt: Point3D, bDrawIso: bool, viewProj: ViewWorldProjection, colorVariant: ARGB, widthVariant: int, refPntAngle: float, offPntAngle: float) None ¶
Create the symbols for an offset point
- Args:
refPnt:        Reference point
offPnt:        Offset point
bDrawIso:      Draw the arrow symbol inside the isometric view: true/false
viewProj:      View world projection data
colorVariant:  Color of the preview
widthVariant:  Width of the symbol
refPntAngle:   Angle at the reference point
offPntAngle:   Angle at the offset point
- OrthogonalSymbol(pnt: Point3D, bDrawIso: bool, viewProj: ViewWorldProjection, colorVariant: ARGB, widthVariant: int) None ¶
Create an orthogonal symbol
- Args:
pnt:           Center point
bDrawIso:      Draw the circle symbol inside the isometric view: true/false
viewProj:      View world projection data
colorVariant:  Color of the preview
widthVariant:  Width of the symbol
- ParallelSymbol(pnt: Point3D, bDrawIso: bool, viewProj: ViewWorldProjection, colorVariant: ARGB, widthVariant: int) None ¶
Create a parallel symbol
- Args:
pnt:           Center point
bDrawIso:      Draw the circle symbol inside the isometric view: true/false
viewProj:      View world projection data
colorVariant:  Color of the preview
widthVariant:  Width of the symbol
- Polyline2DSymbol(refPnt: Point3D, polyline: Polyline2D, viewProj: ViewWorldProjection, colorVariant: ARGB, linePattern: int) None ¶
Create a 2D polyline symbol preview
- Args:
refPnt:        Reference point
polyline:      Polyline
viewProj:      View world projection
colorVariant:  Color of the preview
linePattern:   Line pattern
- Polyline3DSymbol(...)¶
- Polyline3DSymbol(polyline: Polyline3D, viewProj: ViewWorldProjection, colorVariant: ARGB, linePattern: int) None ¶
Create a 3D polyline symbol preview
- Args:
polyline:      3D Polyline
viewProj:      View world projection data
colorVariant:  Color of the preview
linePattern:   Line pattern
- Polyline3DSymbol(refPnt: Point3D, polyline: Polyline3D, viewProj: ViewWorldProjection, colorVariant: ARGB, linePattern: int) None ¶
Create a 3D polyline symbol preview
- Args:
refPnt:        Reference point
polyline:      Polyline
viewProj:      View world projection
colorVariant:  Color of the preview
linePattern:   Line pattern
- TrackLine(line: Line3D, bDrawIso: bool, viewProj: ViewWorldProjection, colorVariant: ARGB, trackLineType: object) None ¶
Create a track line
- Args:
line:           Track line
bDrawIso:       Draw the circle symbol inside the isometric view: true/false
viewProj:       View world projection data
colorVariant:   Color of the preview
trackLineType:  Type of the track line
- TrackMarkSymbol(pnt: Point3D, bDrawIso: bool, viewProj: ViewWorldProjection, colorVariant: ARGB, widthVariant: int) None ¶
Create a track mark symbol
- Args:
pnt:           Center point
bDrawIso:      Draw the circle symbol inside the isometric view: true/false
viewProj:      View world projection data
colorVariant:  Color of the preview
widthVariant:  Width of the symbol
- __init__()¶
This class cannot be instantiated from Python
- __module__ = 'NemAll_Python_IFW_Input'¶