class CreateElementResult

class CreateElementResult.CreateElementResult(elements: ~typing.List[~typing.Any] = <factory>,
                                               handles:
~typing.List[~HandleProperties.HandleProperties] = <factory>
,
                                               preview_elements:
~typing.List[~typing.Any] = <factory>
,
                                               placement_point:
~typing.Optional[~typing.Union[~NemAll_Python_Geometry.Point2D
, ~NemAll_Python_Geometry.Point3D]] = None,
                                               multi_placement:
bool = False
,
                                               preview_symbols:
~typing.Optional[~PreviewSymbols.PreviewSymbols] = None
)

Bases: object

Implementation of the data class for the result of the create_element function

Parameters
  • elements – created element

  • handles – created handles

  • preview_element – created element only for drawing in the preview

  • placement_point – if set, the point is used as global placement point for the elements

  • multi_placement – if True, the elements can be placed multiple times

__eq__(other)

Return self==value.

__init__(elements: ~typing.List[~typing.Any] = <factory>,
         handles:
~typing.List[~HandleProperties.HandleProperties] = <factory>
,
         preview_elements:
~typing.List[~typing.Any] = <factory>
,
         placement_point:
~typing.Optional[~typing.Union[~NemAll_Python_Geometry.Point2D
, ~NemAll_Python_Geometry.Point3D]] = None,
         multi_placement:
bool = False
,
         preview_symbols:
~typing.Optional[~PreviewSymbols.PreviewSymbols] = None
)

Initialize self. See help(type(self)) for accurate signature.

__repr__()

Return repr(self).

is_empty() bool

check for empty data

Returns

True if no elements and handles exist, otherwise False

__module__ = 'CreateElementResult'
elements: List[Any]
handles: List[HandleProperties]
multi_placement: bool = False
placement_point: Optional[Union[Point2D, Point3D]] = None
preview_elements: List[Any]
preview_symbols: Optional[PreviewSymbols] = None