AllplanElement
Canonical path: NemAll_Python_Precast.AllplanElement
Implementation of the Allplan element
GetAttributes
Get the attributes object
Returns:
-
object
–Attributes object
GetBaseElementAdapter
GetBaseElementAdapter() -> BaseElementAdapter
GetCommonProperties
GetCommonProperties() -> CommonProperties
GetGeometryObject
Get the geometry object
Returns:
-
object
–Geometry object
SetAttributes
Set the attributes object
Parameters:
-
attributeContainer
(object
) –Attributes object
SetCommonProperties
SetCommonProperties(commonProp: CommonProperties)
SetDockingPointsKey
Set the docking points key
Parameters:
-
dockingPointsKey
(str
) –Docking points key
SetGeometryObject
Set the geometry object
Parameters:
-
geoObject
(object
) –Geometry object
Placeholder