Skip to content

NemAll_Python_Precast

Exposed classes and functions from NemAll_Python_Precast

Functions:

CreatePrecastElements

CreatePrecastElements(
    doc: DocumentAdapter,
    insertionMat: Matrix3D,
    elements: BaseElementAdapterList,
    modelEleList: list,
    modelUuidList: list,
    viewProj: ViewWorldProjection,
    delete_python: bool,
)

Create the precast elements

Parameters:

  • doc (DocumentAdapter) –

    Document

  • insertionMat (Matrix3D) –

    Insertion matrix

  • elements (BaseElementAdapterList) –

    List of created elements

  • modelEleList (list) –

    List of model elements which have to be created

  • modelUuidList (list) –

    List with the model UUIDS in modification mode

  • viewProj (ViewWorldProjection) –

    View projection

  • delete_python (bool) –

    bool weather the python should be deleted after update

LockPrecastUpdate

LockPrecastUpdate()

Lock the precast update

TriggerPrecastUpdate

TriggerPrecastUpdate(elements: BaseElementAdapterList) -> bool

Trigger the precast update

Parameters:

Returns:

  • bool

    update successful: true/false)

UnlockPrecastUpdate

UnlockPrecastUpdate()

Lock the precast update