Skip to content

HealingSettings

Canonical path: NemAll_Python_Geometry.HealingSettings

Class holding Healing settings for elements.

Methods:

GetPolygonHealingSettings

GetPolygonHealingSettings() -> ePolygonHealingSettings

Get Healing settings for polygon

Returns:

GetPolyhedronHealingSettings

GetPolyhedronHealingSettings() -> ePolyhedronHealingSettings

Get Healing settings for polyhedron

Returns:

IsPolygonNoModify

IsPolygonNoModify() -> bool

Check whether the type of the settings for polygon is PHSET_NOMODIFY

Returns:

  • bool

    true/false.

IsPolygonNormalize

IsPolygonNormalize() -> bool

Check whether the type of the settings for polygon is PHSET_NOMODIFY

Returns:

  • bool

    true/false.

IsPolyhedronNoModify

IsPolyhedronNoModify() -> bool

Check whether the type of the settings for polyhedron is HSET_NOMODIFY

Returns:

  • bool

    true/false.

IsPolyhedronTilt

IsPolyhedronTilt() -> bool

Check whether the type of the settings for polyhedron is HSET_TILT

Returns:

  • bool

    true/false.

IsPolyhedronTriangulate

IsPolyhedronTriangulate() -> bool

Check whether the type of the settings for polyhedron is HSET_TRIANGULATE

Returns:

  • bool

    true/false.

IsPolyhedronUnknown

IsPolyhedronUnknown() -> bool

Check whether the type of the settings for polyhedron is HSET_TRIANGULATE

Returns:

  • bool

    true/false.

IsWeldVerticesEnabled

IsWeldVerticesEnabled() -> bool

Check if vertices welding is enabled

Returns:

  • bool

    true/false.

SetPolygonHealingSettings

SetPolygonHealingSettings(pgonSet: ePolygonHealingSettings)

Set healing settings for polygon.

Parameters:

SetPolyhedronHealingSettings

SetPolyhedronHealingSettings(phedSet: ePolyhedronHealingSettings)

Set healing settings for polyhedron.

Parameters:

SetWeldVertices

SetWeldVertices(enableWeld: bool)

Set vertices welding

Parameters:

  • enableWeld (bool) –

    Enable vertices welding

__init__ overloaded

__init__(
    oPhedType: ePolyhedronHealingSettings = HSET_TRIANGULATE,
    oPgonType: ePolygonHealingSettings = PHSET_NOMODIFY,
    weldVertices: bool = False,
)

Default constructor.

Types can be found in GeometryEnums.h

Parameters:

__init__(hSet: HealingSettings)

Copy constructor.

Parameters: