Skip to content

AttributeSet

Canonical path: NemAll_Python_BaseElements.AttributeSet

Attribute set

Methods:

Attributes:

Attributes property writable

Get the AttributeSet vector

__eq__

__eq__(element: AttributeSet) -> bool

Equal operator

Parameters:

Returns:

  • bool

    Elements are equal: true/false

__init__ overloaded

__init__()

Initialize

__init__(elements: list)

Constructor

Parameters:

  • elements (list) –

    Attribute elements

__init__(element: AttributeSet)

Copy constructor

Parameters:

__ne__

__ne__(element: AttributeSet) -> bool

Unequal operator

Parameters:

Returns:

  • bool

    Elements are unequal: true/false

__repr__

__repr__() -> str

Convert to string