Skip to content

ArchElement

Canonical path: NemAll_Python_ArchElements.ArchElement

Bases: AllplanElement

Abstract base class representing all architectural components

Methods:

Attributes:

ConnectionUUID property writable

ConnectionUUID: GUID

Get the connection UUID

GetConnectionUUID

GetConnectionUUID() -> GUID

Get the connection UUID

Returns:

  • GUID

    Connection UUID

SetConnectionUUID

SetConnectionUUID(connectionGuid: GUID)

Set the connection UUID

Parameters:

  • connectionGuid (GUID) –

    Connection UUID