Skip to content

SnoopElementGeometryFilter

Canonical path: NemAll_Python_IFW_Input.SnoopElementGeometryFilter

Methods:

  • AddElements

    Add elements to the filter

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

AddElements

AddElements(elementNames: str)

Add elements to the filter

Parameters:

  • elementNames (str) –

    Element names, separated by ,

__init__ overloaded

__init__()

Initialize

__init__(
    bFindBaseGeometry: bool,
    bFindAreaGeometry: bool,
    bPerpendicularOnElement: bool,
    bFindNonPassiveOnly: bool,
    bSplitAreaGeometries: bool,
    bIdentifyEmbeddedElement: bool,
    bFindCompleteFootprint: bool,
    splitElement3D: eSplitElement3D,
)

Constructor

Passive geometry is virtual geometry which is using for element snooping. Typical passive geometry is boundary area around text. This area has no edges like a Hatching, but if cursor is inside this area, then element must be snooped. Passive geometry has no points, perpendicular points, edges, etc. .

Parameters:

  • bFindBaseGeometry (bool) –

    If true, find the base geometry element (e.g. line from polyline)

  • bFindAreaGeometry (bool) –

    If true, the service adds the nearest area geometry if nothing else is found

  • bPerpendicularOnElement (bool) –

    If true, the service adds perpendicular geometry

  • bFindNonPassiveOnly (bool) –

    If true, then only non passive geometry will be searching

  • bSplitAreaGeometries (bool) –

    If true, find the line geometry element for area geometries (e.g line from polygon)

  • bIdentifyEmbeddedElement (bool) –

    If true, find elements from embedded documents

  • bFindCompleteFootprint (bool) –

    If true, find the complete footprint of a wall instead of the footprint of the wall tier

  • splitElement3D (eSplitElement3D) –

    Split the 3D element geometry ---> in case of bFindBaseGeometry the split is always done to edges !!!