Skip to content

MeshOperations

Canonical path: NemAll_Python_Reinforcement.MeshOperations

Methods:

CutMesh staticmethod

CutMesh(placements: BaseElementAdapter, divisionLine: Polygon2D) -> str

Divide the bars placement

Returns:

  • str

    Result message

Parameters:

  • placement

    BaseElementAdapter with the placement

  • cutPolygon

    Cut polygon

__init__

__init__()

Initialize