Skip to content

WallElement

Canonical path: NemAll_Python_ArchElements.WallElement

Bases: ArchElement, AllplanElement

Representation of a multilayer wall

Methods:

Attributes:

Properties property writable

Properties: WallProperties

Properties of the wall

GetProperties

GetProperties() -> WallProperties

Get the wall properties

Returns:

SetCommonProperties

SetCommonProperties(commonProp: CommonProperties)

Set the common properties

Parameters:

SetProperties

SetProperties(wallProp: WallProperties)

Set the wall properties

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(wallProp: WallProperties, axis: object)

Constructor

Parameters:

  • wallProp (WallProperties) –

    Wall properties

  • axis (object) –

    Axis

__init__(element: WallElement)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string