Skip to content

ElevationElement

Canonical path: NemAll_Python_BasisElements.ElevationElement

Bases: DimensionLineElement, BasisElement, AllplanElement

ElevationElement class

Methods:

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert the list to a string

__init__ overloaded

__init__()

Initialize

__init__(
    dimensionPoints: Point3DList,
    placementVector: Vector2D,
    directionVector: Vector2D,
    settings: DimensionProperties,
)

Constructor

Parameters:

  • dimensionPoints (Point3DList) –

    Elevation points

  • placementVector (Vector2D) –

    Placement vector to the first elevation point

  • directionVector (Vector2D) –

    Direction vector

  • settings (DimensionProperties) –

    Elevation settings

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string