Skip to content

FixturePlacementProperties

Canonical path: NemAll_Python_Precast.FixturePlacementProperties

FixturePlacementProperties class

Methods:

Attributes:

Automation property

Automation: None

Value type: bool

:type: None

ConnectionToAIACatalog property

ConnectionToAIACatalog: None

Enable connection to the Precast Fixture catalog of the Fixture placement element

Value type: bool

:type: None

ConnectionToAllplanCatalog property

ConnectionToAllplanCatalog: None

Enable connection to the Allplan Catalog of the Fixture placement element

Value type: bool

:type: None

CountOfQuestions property

CountOfQuestions: None

Number of active question attributes of the Fixture placement element

Value type: int

:type: None

DistortionState property

DistortionState: None

Value type: bool

:type: None

DomainType property

DomainType: None

Domaintype of the Fixture placement element

Value type: None

:type: None

EnableQuestions property

EnableQuestions: None

Enables the question attributes of the Fixture placement element

Value type: bool

:type: None

HasParentModificationBehaviour property

HasParentModificationBehaviour: None

Property for specific behavior for modification state Value type: bool

:type: None

HeightDefinitionType property writable

HeightDefinitionType: HeightDefinitionType

Get the Height definition type

HollowShaft property

HollowShaft: None

Value type: bool

:type: None

Mass_V6 property

Mass_V6: None

Value type: float

:type: None

Mass_V7 property

Mass_V7: None

Value type: float

:type: None

Mass_V8 property

Mass_V8: None

Value type: float

:type: None

Mass_V9 property

Mass_V9: None

Value type: float

:type: None

Matrix property writable

Matrix: Matrix3D

Get the Matrix for location in world coordinate system

MirrorState property

MirrorState: None

Property for the fixture placement mirrored state Value type: bool

:type: None

Name property

Name: None

Name of the Fixture placement element

Value type: str

:type: None

OutlineShape property

OutlineShape: None

Value type: OutlineShape

:type: None

OutlineType property

OutlineType: None

Value type: OutlineType

:type: None

OutlineTypeInGroup property

OutlineTypeInGroup: None

Value type: OutlineTypeInGroup

:type: None

PositionNr property

PositionNr: None

Value type: int

:type: None

ProfilType property

ProfilType: None

Value type: ProfilType

:type: None

SubType property

SubType: None

SubType of the Fixture placement element

Value type: MacroSubType

:type: None

Type property

Type: None

Type of the Fixture placement element

Value type: MacroType

:type: None

UnitFactor property

UnitFactor: None

Value type: int

:type: None

UseAlways2DRepInGroundView property

UseAlways2DRepInGroundView: None

Value type: bool

:type: None

UseDrawOrder property writable

UseDrawOrder: bool

Get the Uses the draw order setting of the placement or the elements of the Fixture ?

UseFormat property writable

UseFormat: bool

Get the Uses the format setting (pen, stroke, color) of the placement or the elements of the Fixture ?

Visibility property

Visibility: None

Value type: bool

:type: None

__eq__

__eq__(prop: FixturePlacementProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string