Skip to content

AngleList

Canonical path: NemAll_Python_Geometry.AngleList

List for Angle objects

Methods:

  • __contains__

    Check for a value in the list

  • __delitem__

    Delete a list item

  • __eq__

    Compare two lists

  • __getitem__

    Get a list item

  • __iadd__

    Add a list

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __iter__

    List iterator

  • __len__

    Get the list length

  • __repr__

    Create a string from the elements of the list

  • __setitem__

    Set a list item

  • append

    Append a list item

  • extend

    dummy, is only needed for the creation of the documentation by MkDocs

__contains__

__contains__(value: Angle) -> bool

Check for a value in the list

Parameters:

  • value (Angle) –

    Value to check

Returns:

  • bool

    State for value is in the list

__delitem__

__delitem__(value: Angle)

Delete a list item

Parameters:

  • value (Angle) –

    Value to delete

__eq__

__eq__(compare_list: AngleList) -> bool

Compare two lists

Parameters:

  • compare_list (AngleList) –

    List to compare

Returns:

  • bool

    Lists are equal state

__getitem__

__getitem__(index: int) -> Angle

Get a list item

Parameters:

  • index (int) –

    Index of the item

Returns:

  • Angle

    Value for the index

__iadd__

__iadd__(eleList: list) -> AngleList

Add a list

Parameters:

  • eleList (list) –

    Angle list

Returns:

  • AngleList

    Lists with the added elements

__init__ overloaded

__init__()

Initialize

__init__(ele: Angle)

Constructor with a Angle

Parameters:

__init__(eleList: list)

Constructor with a list of Angle

Parameters:

  • eleList (list) –

    Angle list

__iter__

__iter__() -> Iterator

List iterator

Returns:

  • Iterator

    List iterator

__len__

__len__() -> int

Get the list length

Returns:

  • int

    Length of the list

__repr__

__repr__() -> str

Create a string from the elements of the list

__setitem__

__setitem__(index: int | slice, value: Angle)

Set a list item

Parameters:

  • index (int | slice) –

    Index of the item

  • value (Angle) –

    Value to item

append

append(value: Angle)

Append a list item

Parameters:

  • value (Angle) –

    Value to append

extend overloaded

extend(iterable: AngleList)

Add the items from an iterable to the end of the list

Parameters:

extend(eleList: list)

Extend the list

Parameters:

  • eleList (list) –

    Angle list