Skip to content

Polyline3D

Canonical path: NemAll_Python_Geometry.Polyline3D

Bases: PolyPoints3D

Representation class for 3D Polyline.

Methods:

  • GetLine

    Extract a line

  • GetLines

    get lines from polyline

  • InsertPolyline

    Insert another polyline at given position

  • IsPlanar

    Check if polyline is on one plane

  • IsValid

    Check if the polygon is valid ( has at least 2 points )

  • LineCount

    Get the count of lines connecting the points

  • Reverse

    Reverse Polyline orientation

  • __eq__

    Equal operator

  • __iadd__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __mul__

    Multiple Polyline with matrix

  • __ne__

    Not equal operator

  • __repr__

    Convert to string

GetLine

GetLine(index: int) -> Line3D

Extract a line

Parameters:

  • index (int) –

    Index of the line

Returns:

GetLines

GetLines() -> Line3DList

get lines from polyline

Returns:

InsertPolyline

InsertPolyline(
    polyline: Polyline3D, position: int = 18446744073709551615
) -> bool

Insert another polyline at given position

Parameters:

  • polyline (Polyline3D) –

    Polyline to be inserted

  • position (int, default: 18446744073709551615 ) –

    Position where the polyline has to be inserted

Returns:

  • bool

    true if successful

IsPlanar

IsPlanar() -> tuple[bool, Plane3D]

Check if polyline is on one plane

Returns:

  • tuple[bool, Plane3D]

    tuple(True if polyline is on one plane, if polyline is on one plane the plane is calculated)

IsValid

IsValid() -> bool

Check if the polygon is valid ( has at least 2 points )

For additional point validation use Service::Validate.

Returns:

  • bool

    true if is valid

LineCount

LineCount() -> int

Get the count of lines connecting the points

Returns:

  • int

    count of lines

Reverse

Reverse()

Reverse Polyline orientation

__eq__

__eq__(polyline2: Polyline3D) -> bool

Equal operator

Parameters:

Returns:

  • bool

    Polyline3D are equal

__iadd__ overloaded

__iadd__(polyline: Polyline3D) -> Polyline3D

Additional assignment operator

Parameters:

  • polyline (Polyline3D) –

    Polyline which will be added to current polyline

Returns:

__iadd__(point: Point3D) -> Polyline3D

Addition assignment operator

Parameters:

  • point (Point3D) –

    New Point3D which will be added to the polyline

Returns:

__iadd__(line: Line3D) -> Polyline3D

Addition assignment operator

Parameters:

  • line (Line3D) –

    Line3D which will be added to the polyline

Returns:

__init__ overloaded

__init__()

Initialize

__init__(pntList: list[Point3D])

Constructor with an initializer list

Parameters:

  • pntList (list[Point3D]) –

    Point list

__init__(polyline: Polyline3D)

Copy constructor

Parameters:

  • polyline (Polyline3D) –

    Polyline which will be copied

__init__(polyline: Polyline3D, skip: int, count: int)

Copy constructor with limited scope

Parameters:

  • polyline (Polyline3D) –

    Polyline which will be copied

  • skip (int) –

    count of points ignored at start.

  • count (int) –

    count of points copied.

__init__(points: Point3DList)

Vector points constructor.

Parameters:

  • points (Point3DList) –

    Vector of points which will be moved to polyline

__mul__

__mul__(matrix: Matrix3D) -> Polyline3D

Multiple Polyline with matrix

Parameters:

  • matrix (Matrix3D) –

    Transformation matrix

Returns:

__ne__

__ne__(polyline2: Polyline3D) -> bool

Not equal operator

Parameters:

Returns:

  • bool

    Polyline3D are equal

__repr__

__repr__() -> str

Convert to string