Skip to content

title: Element Select Filter Setting description: Class containing settings for filtering elements during element selection, such as:


ElementSelectFilterSetting

Canonical path: NemAll_Python_IFW_Input.ElementSelectFilterSetting

Class containing settings for filtering elements during element selection, such as:

  • which layer to consider (active, passive, both)
  • which document to consider (active, passive, both)
  • query for specific element types

Methods:

Attributes:

LayerSelectType property writable

LayerSelectType: eLayerSnoopType

Get the layer selection type

Clear

Clear()

Reset the settings

GetLayerSelectType

GetLayerSelectType() -> eLayerSnoopType

Get the layer selection type

Returns:

IsBaseClassType staticmethod

IsBaseClassType(typeID: GUID) -> bool

Check, whether the element type is a base class type

Parameters:

  • typeID (GUID) –

    Element type ID

Returns:

  • bool

    Element type is a base class type: true/false

IsClear

IsClear() -> bool

Get the clear state

Returns:

  • bool

    true, if the members contain default values

IsPointSelect

IsPointSelect() -> bool

Get the point select state

Returns:

  • bool

    Point selection is active: true/false

IsSelectPassiveInfoElement

IsSelectPassiveInfoElement() -> bool

Get the selection state of a passive info element

Returns:

  • bool

    Allow to select passive info element if no active element was found: true/false

SelectPassiveInfoElement

SelectPassiveInfoElement()

Allow to select passive info element if no active element was found

SetArchitectureFilterQuery

SetArchitectureFilterQuery(positive: bool = True)

Set a prefabricated filter for all architecture elements

Parameters:

  • positive (bool, default: True ) –

    if the filter will true for architecture elements otherwise the filter will be false for architecture elements

SetAssoFilterQuery

SetAssoFilterQuery(positive: bool = True)

Set a prefabricated filter for all associative view elements

Parameters:

  • positive (bool, default: True ) –

    if the filter will true for associative view elements otherwise the filter will be false for associative view elements

SetDocumentLayerFilter

SetDocumentLayerFilter(bSnoopAllElements: bool)

Set the document and layer filter

Parameters:

  • bSnoopAllElements (bool) –

    Snoop all elements: true/false

SetDocumentSelectType

SetDocumentSelectType(documentSnoopType: eDocumentSnoopType)

Set the selection mode for the document (active, passive or all documents)

Parameters:

  • documentSnoopType (eDocumentSnoopType) –

    Selection mode for the document (active, passive or all documents)

SetLayerSelectType

SetLayerSelectType(layerSnoopType: eLayerSnoopType)

Set the layer selection type

Parameters:

  • layerSnoopType (eLayerSnoopType) –

    Type of the allowed layers for the selection

SetPointSelect

SetPointSelect()

Set the point select state

__init__ overloaded

__init__()

Construct the filter with default settings:

  • filter only active layers (eSnoopActiveLayers)
  • filter only active documents (eSnoopActiveDocuments)
  • query is empty (all elements can be selected)
__init__(bSnoopAllElements: bool)

Construct the filter with an empty element type query (all type of elements can be selected)

Parameters:

  • bSnoopAllElements (bool) –

    True will consider elements on both active and passive layers and documents. False will consider elements on active layers and documents only

__init__(filter: SelectionQuery, bSnoopAllElements: bool)

Construct the filter with a custom element type query

Parameters:

  • filter (SelectionQuery) –

    Query for specific elements to search for

  • bSnoopAllElements (bool) –

    True will consider elements on both active and passive layers and documents. False will consider elements on active layers and documents only

__init__(
    filter: SelectionQuery,
    documentSnoopType: eDocumentSnoopType = eSnoopActiveDocuments,
    layerSnoopType: eLayerSnoopType = eSnoopActiveLayers,
)

Construct the filter with a custom element type query and separate search settings for documents and layers.

Parameters:

__init__(selectSetting: ElementSelectFilterSetting)

Copy Constructor

Parameters: