Skip to content

AttributeStringVec

Canonical path: NemAll_Python_BaseElements.AttributeStringVec

Bases: Attribute

StringVec attribute

Methods:

  • __eq__

    Equal operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __ne__

    Unequal operator

  • __repr__

    Convert to string

Attributes:

Value property writable

Get the attribute value

__eq__

__eq__(element: AttributeStringVec) -> bool

Equal operator

Parameters:

Returns:

  • bool

    Elements are equal: true/false

__init__ overloaded

__init__()

Initialize

__init__(id: int, value: VecStringList)

Constructor

Parameters:

  • id (int) –

    Attribute id

  • value (VecStringList) –

    Attribute value

__init__(element: AttributeStringVec)

Copy constructor

Parameters:

__ne__

__ne__(element: AttributeStringVec) -> bool

Unequal operator

Parameters:

Returns:

  • bool

    Elements are unequal: true/false

__repr__

__repr__() -> str

Convert to string