Skip to content

HiddenMaterial

Canonical path: NemAll_Python_Geometry.HiddenMaterial

Input element settings used by hidden calculation.

Methods:

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

Attributes:

ExtraSmooth property writable

ExtraSmooth: bool

Extra smooth flag for entry.

Flag is usual for elements like round column. Adjacent edges of such element are optimized with constant angle (20 deg) ignoring angle set in hidden options (usual about 1deg).

MaterialNumber property writable

MaterialNumber: int

So called material number of entry.

Elements with same material numbers are threaded specially depending on settings of hidden calculation e.g suspended lines between them etc. Value 0 means no material set.

__init__ overloaded

__init__()

Initialize

__init__(source: HiddenMaterial)

Copy constructor.

Parameters: