Skip to content

BuildingElementInputControls

Canonical path: NemAll_Python_IFW_Input.BuildingElementInputControls

Implementation of the building element input controls

Methods:

CloseControls

CloseControls()

Close the input controls

CreateControls

CreateControls(
    handlePropList: object,
    insertionMat: Matrix3D,
    viewProj: ViewWorldProjection,
    bUpdateControls: bool,
    assoRefObj: object,
)

Create the controls

Parameters:

  • handlePropList (object) –

    List with the handle properties

  • insertionMat (Matrix3D) –

    Transformation matrix

  • viewProj (ViewWorldProjection) –

    View world projection

  • bUpdateControls (bool) –

    Update the controls: true/false

  • assoRefObj (object) –

    Reference element for the drawing inside the associative views

__init__ overloaded

__init__()

Initialize

__init__(element: BuildingElementInputControls)

Copy constructor

Parameters: