Skip to content

DivideBarsParameters

Canonical path: NemAll_Python_Reinforcement.DivideBarsParameters

Parameters for dividing engineering geometry

Classes:

Methods:

  • GetTrimLens

    Get necessary length to lengthen/shorten bar parts

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert the list to a string

Attributes:

DivideMode property writable

DivideMode: eDivideMode

Get the mode of division

GapLength property writable

GapLength: float

Get the gap length

GapPosition property writable

GapPosition: eLengthPosition

Get the position of gap

OverlapLength property writable

OverlapLength: float

Get the overlap length

OverlapPosition property writable

OverlapPosition: eLengthPosition

Get the position of overlap

eDivideMode

Canonical path: NemAll_Python_Reinforcement.DivideBarsParameters.eDivideMode

Bases: Enum

Information of Divide Mode

Methods:

__getitem__

__getitem__(key: str | int | float) -> eDivideMode

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

eInputMode

Canonical path: NemAll_Python_Reinforcement.DivideBarsParameters.eInputMode

Bases: Enum

Information of input mode

Methods:

__getitem__

__getitem__(key: str | int | float) -> eInputMode

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

eLengthPosition

Canonical path: NemAll_Python_Reinforcement.DivideBarsParameters.eLengthPosition

Bases: Enum

Information of position of Overlap-/Gap-Length

Methods:

__getitem__

__getitem__(key: str | int | float) -> eLengthPosition

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

GetTrimLens

GetTrimLens() -> tuple[float, float]

Get necessary length to lengthen/shorten bar parts

Returns:

  • tuple[float, float]

    tuple(lengthen/shorten left bar part, lengthen/shorten right bar part)

__init__ overloaded

__init__()

Initialize

__init__(
    DivideMode: eDivideMode,
    OverlapPosition: eLengthPosition,
    OverlapLength: float,
    GapPosition: eLengthPosition,
    GapLength: float,
)

Constructor

Parameters:

  • DivideMode (eDivideMode) –

    Mode of division

  • OverlapPosition (eLengthPosition) –

    Position of Overlap

  • OverlapLength (float) –

    Overlap length

  • GapPosition (eLengthPosition) –

    Position of Gap

  • GapLength (float) –

    Gap length

__init__(element: DivideBarsParameters)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string