Skip to content

Arc2DList

Canonical path: NemAll_Python_Geometry.Arc2DList

List for Arc2D objects

Methods:

  • __contains__

    Check for a value in the list

  • __delitem__

    Delete a list item

  • __eq__

    Compare two lists

  • __getitem__

    Get a list item

  • __iadd__

    Add a list

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __iter__

    List iterator

  • __len__

    Get the list length

  • __repr__

    Create a string from the elements of the list

  • __setitem__

    Set a list item

  • append

    Append a list item

  • extend

    dummy, is only needed for the creation of the documentation by MkDocs

__contains__

__contains__(value: Arc2D) -> bool

Check for a value in the list

Parameters:

  • value (Arc2D) –

    Value to check

Returns:

  • bool

    State for value is in the list

__delitem__

__delitem__(value: Arc2D)

Delete a list item

Parameters:

  • value (Arc2D) –

    Value to delete

__eq__

__eq__(compare_list: Arc2DList) -> bool

Compare two lists

Parameters:

  • compare_list (Arc2DList) –

    List to compare

Returns:

  • bool

    Lists are equal state

__getitem__

__getitem__(index: int) -> Arc2D

Get a list item

Parameters:

  • index (int) –

    Index of the item

Returns:

  • Arc2D

    Value for the index

__iadd__

__iadd__(eleList: list) -> Arc2DList

Add a list

Parameters:

  • eleList (list) –

    Arc2D list

Returns:

  • Arc2DList

    Lists with the added elements

__init__ overloaded

__init__()

Initialize

__init__(ele: Arc2D)

Constructor with a Arc2D

Parameters:

__init__(eleList: list)

Constructor with a list of Arc2D

Parameters:

  • eleList (list) –

    Arc2D list

__iter__

__iter__() -> Iterator

List iterator

Returns:

  • Iterator

    List iterator

__len__

__len__() -> int

Get the list length

Returns:

  • int

    Length of the list

__repr__

__repr__() -> str

Create a string from the elements of the list

__setitem__

__setitem__(index: int | slice, value: Arc2D)

Set a list item

Parameters:

  • index (int | slice) –

    Index of the item

  • value (Arc2D) –

    Value to item

append

append(value: Arc2D)

Append a list item

Parameters:

  • value (Arc2D) –

    Value to append

extend overloaded

extend(iterable: Arc2DList)

Add the items from an iterable to the end of the list

Parameters:

extend(eleList: list)

Extend the list

Parameters:

  • eleList (list) –

    Arc2D list