Skip to content

SectionGeneralProperties

Canonical path: NemAll_Python_BasisElements.SectionGeneralProperties

General properties of the UVS

Classes:

Methods:

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

Attributes:

FilterProperties property

FilterProperties: None

Filtering settings of the UVS

FormatProperties property

FormatProperties: None

Format settings of a UVS

HiddenSectionLinesProperties property

HiddenSectionLinesProperties: None

Settings regarding hidden section lines in the UVS

LabelingProperties property

LabelingProperties: None

Settings regarding labeling the UVS

PlacementAngle property

PlacementAngle: None

Property for the placement angle

:type: None

PlacementPoint property

PlacementPoint: None

Property for the placement point

:type: None

PlacementPointType property

PlacementPointType: None

Position of the placement point relative to the UVS (bottom left, top right, etc...)

ShowSectionBody property

ShowSectionBody: None

Whether to show the section body in the UVS

Status property

Status: None

Type of the UVS calculation

VisibleHiddenEdgesProperties property

VisibleHiddenEdgesProperties: None

Settings regarding hidden and visible lines in the UVS

PlacementPointPosition

Canonical path: NemAll_Python_BasisElements.SectionGeneralProperties.PlacementPointPosition

Bases: Enum

Placement point position

Methods:

__getitem__

__getitem__(key: str | int | float) -> PlacementPointPosition

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

State

Canonical path: NemAll_Python_BasisElements.SectionGeneralProperties.State

Bases: Enum

Type of UVS calculation

Methods:

Attributes:

  • AcceleratedHidden

    Draws section using hidden calculation with higher performance and lower quality

  • Hidden

    Hidden calculation, where visible and hidden edges are drawn differently

  • Wire

    Wireframe calculation, where all visible and hidden edges are drawn equally

AcceleratedHidden class-attribute instance-attribute

AcceleratedHidden = 2

Draws section using hidden calculation with higher performance and lower quality

Hidden class-attribute instance-attribute

Hidden = 0

Hidden calculation, where visible and hidden edges are drawn differently

Wire class-attribute instance-attribute

Wire = 1

Wireframe calculation, where all visible and hidden edges are drawn equally

__getitem__

__getitem__(key: str | int | float) -> State

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

  • State

    value for the key

__init__ overloaded

__init__()

Initialize

__init__(bInitFromSTW: bool)

constructor

Parameters:

  • bInitFromSTW (bool) –
    • is structure initialized from standard values