Skip to content

AllplanGlobalSettings

Canonical path: NemAll_Python_AllplanSettings.AllplanGlobalSettings

Utility for reading the current global Allplan settings

Methods:

GetCurrentColorId staticmethod

GetCurrentColorId() -> int

Get the current used color ID in Allplan

Returns:

  • int

    Current color ID

GetCurrentCommonProperties staticmethod

GetCurrentCommonProperties() -> CommonProperties

Get the current common properties

Returns:

GetCurrentFaceStyleId staticmethod

GetCurrentFaceStyleId() -> int

Get the current used face style ID in Allplan

Returns:

  • int

    Current face style ID

GetCurrentFontId staticmethod

GetCurrentFontId() -> int

Get the current used font ID in Allplan

Returns:

  • int

    Current font ID

GetCurrentHatchId staticmethod

GetCurrentHatchId() -> int

Get the current used hatch ID in Allplan

Returns:

  • int

    Current hatch ID

GetCurrentLayerId staticmethod

GetCurrentLayerId() -> int

Get the current used layer ID in Allplan

Returns:

  • int

    Current layer ID

GetCurrentPatternId staticmethod

GetCurrentPatternId() -> int

Get the current used pattern ID in Allplan

Returns:

  • int

    Current pattern ID

GetCurrentPenId staticmethod

GetCurrentPenId() -> int

Get the current used pen ID in Allplan

Returns:

  • int

    Current pen ID

GetCurrentStrokeId staticmethod

GetCurrentStrokeId() -> int

Get the current used stroke ID in Allplan

Returns:

  • int

    Current stroke ID

GetOffsetPoint staticmethod

GetOffsetPoint() -> Point3D

Get the project offset of the currently active project

Returns:

  • Point3D

    Project offset as point