Skip to content

FilletCalculus3D

Canonical path: NemAll_Python_Geometry.FilletCalculus3D

Class for 3D fillet calculation

Methods:

  • Calculate

    dummy, is only needed for the creation of the documentation by MkDocs

Calculate overloaded

Calculate(line1: Line3D, line2: Line3D, radius: float) -> tuple

Calculate fillet between two coplanar 3d lines

Parameters:

  • line1 (Line3D) –

    first Line3D

  • line2 (Line3D) –

    second Line3D

  • radius (float) –

    radius of fillet

Returns:

  • tuple

    error code,

  • tuple

    resulting first Line3D

  • tuple

    resulting second Line3D

  • tuple

    calculated fillet

Calculate(line1: Line3D, line2: Line3D) -> tuple

Calculate fillet between two parallel non collinear 3d lines. The end point of the first line must lie on the same plane as start point of the second line and plane is perpendicular to both lines.

Parameters:

  • line1 (Line3D) –

    first Line3D

  • line2 (Line3D) –

    second Line3D

Returns:

  • tuple

    error code,

  • tuple

    calculated fillet

Calculate(
    line1: Line3D,
    endPoint: eLinePointIdentification,
    polyline: Polyline3D,
    startLineIndex: int,
    endLineIndex: int,
    radius: float,
) -> tuple

Calculate fillet between line1 and line2. Line2 is created as line between end point of line1 (by parameter endPoint) and point from polyline (limited with startPointIndex and endPointIndex)

Parameters:

  • line1 (Line3D) –

    Line 1 for fillet

  • endPoint (eLinePointIdentification) –

    Sign for line2 (from where point of line1 should be start line2)

  • polyline (Polyline3D) –

    Polyline (buffer of end points for line2)

  • startLineIndex (int) –

    Start point index for polyline

  • endLineIndex (int) –

    End point index for polyline

  • radius (float) –

    radius of fillet

Returns:

  • tuple

    error code,

  • tuple

    Line 1 from fillet calculation,

  • tuple

    Line 2 from fillet calculation,

  • tuple

    Calculated fillet

Calculate(
    polyhedron: Polyhedron3D,
    edges: VecSizeTList,
    radius: float,
    propagation: bool,
) -> tuple

Calculate fillet on selected edges of given Polyhedron3D

Parameters:

  • polyhedron (Polyhedron3D) –

    polyhedron to fillet

  • edges (VecSizeTList) –

    edges to fillet

  • radius (float) –

    fillet sphere radius

  • propagation (bool) –

    flag for propagation of neighboring edges

Returns:

  • tuple

    error code,

  • tuple

    resulting BRep3D

Calculate(brep: BRep3D, radius: float) -> tuple

Calculate fillet on all edges of given BRep3D

Parameters:

  • brep (BRep3D) –

    brep to fillet

  • radius (float) –

    fillet sphere radius

Returns:

Calculate(
    brep: BRep3D, edges: VecSizeTList, radius: float, propagation: bool
) -> tuple

Calculate fillet on selected edges of given BRep3D

Parameters:

  • brep (BRep3D) –

    brep to fillet

  • edges (VecSizeTList) –

    edges to fillet

  • radius (float) –

    fillet sphere radius

  • propagation (bool) –

    flag for propagation of neighboring edges

Returns: