Skip to content

MeshPlacement

Canonical path: NemAll_Python_Reinforcement.MeshPlacement

Bases: ReinfElement, AllplanElement

Methods:

GetBendingShape

GetBendingShape() -> BendingShape

Get the shape polyline

Returns:

GetPositionNumber

GetPositionNumber() -> int

Get the position number

Returns:

  • int

    Position number

GetWidthVector

GetWidthVector() -> Vector3D

Get the width vector

Returns:

Move

Move(transVec: Vector3D)

Move the placement

Parameters:

SetBendingShape

SetBendingShape(shape: BendingShape)

Set the reinforcement shape

Parameters:

SetPositionNumber

SetPositionNumber(positionNumber: int)

Set the position number

Parameters:

  • positionNumber (int) –

    Position number

SetWidthVector

SetWidthVector(widthVec: Vector3D)

Set the width vector

Parameters:

Transform

Transform(transMat: Matrix3D)

Transform the placement

Parameters:

  • transMat (Matrix3D) –

    Transformation matrix

__init__ overloaded

__init__()

Initialize

__init__(positionNumber: int, widthVec: Vector3D, bendingShape: BendingShape)

Constructor

Parameters:

  • positionNumber (int) –

    Position number

  • widthVec (Vector3D) –

    Width vector of the mesh

  • bendingShape (BendingShape) –

    Mesh shape

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string