Skip to content

MeshAreaPlacementProperties

Canonical path: NemAll_Python_Reinforcement.MeshAreaPlacementProperties

Classes:

Methods:

Attributes:

LapJointOffset property

LapJointOffset: None

Get/set the lap joint offset state

:type: None

MeshSizeRound property

MeshSizeRound: None

Get/set the mesh size round state

:type: None

OverlapCross property

OverlapCross: None

Get/set the cross overlap

:type: None

OverlapLongitudinal property

OverlapLongitudinal: None

Get/set the longitudinal overlap

:type: None

PlacementDirection property

PlacementDirection: None

Get/set the placement direction

:type: None

PlacementEndJustified property

PlacementEndJustified: None

Get/set the placement end justified state

:type: None

PlacementStartChange property

PlacementStartChange: None

Get/set the placement start change state

:type: None

StartLength property

StartLength: None

Get/set the start length

:type: None

StartWidth property

StartWidth: None

Get/set the start width

:type: None

MeshPlacementDirection

Canonical path: NemAll_Python_Reinforcement.MeshAreaPlacementProperties.MeshPlacementDirection

Bases: Enum

Mesh placement direction

Methods:

__getitem__

__getitem__(key: str | int | float) -> MeshPlacementDirection

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string