Skip to content

LibraryElement

Canonical path: NemAll_Python_BasisElements.LibraryElement

Bases: BasisElement, AllplanElement

Representation of an element from the Allplan library

An element from Allplan library can be a symbol, smart symbol or fixture. This class represents also fixtures from fixture catalogs

Methods:

GetCount

GetCount() -> int

Get the element count

Returns:

  • int

    Element count

GetGeometryElements

GetGeometryElements(doc: DocumentAdapter) -> list

Get the geometry elements

Parameters:

Returns:

  • list

    Geometry elements

GetMinMax

GetMinMax(doc: DocumentAdapter) -> MinMax3D

Get the min/max box of the element

Parameters:

Returns:

  • MinMax3D

    Min/max box of the element

GetProperties

GetProperties() -> LibraryElementProperties

Get the properties

Returns:

GetReferencePoint

GetReferencePoint(doc: DocumentAdapter) -> Point3D

Get the reference point

Parameters:

Returns:

Move

Move(moveVec: Vector3D)

Move the element

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(libEleProp: LibraryElementProperties)

Constructor

Parameters:

__init__(libEle: LibraryElement)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string