Skip to content

SpiralElement

Canonical path: NemAll_Python_Reinforcement.SpiralElement

Bases: ReinfElement, AllplanElement

Methods:

SetLengthFactor

SetLengthFactor(arg2: float)

Get the length factor

Returns:

  • Length factor

SetNumberLoopsEnd

SetNumberLoopsEnd(arg2: int)

Set the loops at the end

SetNumberLoopsStart

SetNumberLoopsStart(arg2: int)

Set the loops at the start

SetPitchSections

SetPitchSections(
    pitch1: float,
    length1: float,
    pitch2: float,
    length2: float,
    pitch3: float,
    length3: float,
    pitch4: float,
    length4: float,
)

Set the pitch section

Parameters:

  • pitch1 (float) –

    Pitch section 1

  • length1 (float) –

    Length section 1

  • pitch2 (float) –

    Pitch section 2

  • length2 (float) –

    Length section 2

  • pitch3 (float) –

    Pitch section 3

  • length3 (float) –

    Length section 3

  • pitch4 (float) –

    Pitch section 4

  • length4 (float) –

    Length section 4

SetPlacePerLinearMeter

SetPlacePerLinearMeter(bPlacePerMeter: bool)

Set the place per linear meter state

Parameters:

  • bPlacePerMeter (bool) –

    Place per linear meter: true/false

__init__ overloaded

__init__()

Initialize

__init__(
    positionNumber: int,
    diameter: float,
    steelGrade: int,
    concreteGrade: int,
    rotationAxis: Line3D,
    contourPoints: Polyline3D,
    pitch: float,
    hookLengthStart: float,
    hookAngleStart: float,
    hookLengthEnd: float,
    hookAngleEnd: float,
    concreteCoverStart: float,
    concreteCoverEnd: float,
    concreteCoverContour: float,
)

Constructor

Parameters:

  • positionNumber (int) –

    Position number

  • diameter (float) –

    Diameter

  • steelGrade (int) –

    Steel grade

  • concreteGrade (int) –

    Concrete grade

  • rotationAxis (Line3D) –

    Rotation axis

  • contourPoints (Polyline3D) –

    Contour points

  • pitch (float) –

    Pitch

  • hookLengthStart (float) –

    Hook length at the start

  • hookAngleStart (float) –

    Hook angle at the start

  • hookLengthEnd (float) –

    Hook length at the end

  • hookAngleEnd (float) –

    Hook angle at the end

  • concreteCoverStart (float) –

    Concrete cover at the start

  • concreteCoverEnd (float) –

    Concrete cover at the end

  • concreteCoverEnd (float) –

    Concrete cover at the contour