Skip to content

LibraryElementProperties

Canonical path: NemAll_Python_BasisElements.LibraryElementProperties

Properties of the library element

Methods:

Attributes:

PlacementMatrices property writable

PlacementMatrices: Matrix3DList

Get the placement matrices

PlacementMatrix property writable

PlacementMatrix: Matrix3D

Get the placement matrix

Polyline property writable

Polyline: Polyline3D

Get the polygon points in case of a line fixture

Producer property writable

Producer: str

Get the producer

GetElement

GetElement() -> str

Get the element

Returns:

  • str

    Element

GetElementType

GetElementType() -> LibraryElementType

Get the element type

Returns:

GetGroup

GetGroup() -> str

Get the group

Returns:

  • str

    Group

GetPath

GetPath() -> str

Get the path

Returns:

  • str

    Path

GetPlacementMatrices

GetPlacementMatrices() -> Matrix3DList

Get the placement matrices

Returns:

GetPlacementMatrix

GetPlacementMatrix() -> Matrix3D

Get the placement matrix

Returns:

GetPolyline

GetPolyline() -> Polyline3D

Get the polygon points in case of a line fixture

Returns:

  • Polyline3D

    Polyline points of the line fixture

GetProducer

GetProducer() -> str

Get the producer

Returns:

  • str

    Producer

GetSingleFilePath

GetSingleFilePath() -> str

Get the Single File Path

Returns:

  • str

    SingleFilePath

SetPlacementMatrices

SetPlacementMatrices(placementMatrices: Matrix3DList)

Set the placement matrices

Parameters:

SetPlacementMatrix

SetPlacementMatrix(placementMatrix: Matrix3D)

Set the placement matrix

Parameters:

  • placementMatrix (Matrix3D) –

    Placement matrix

SetPolyline

SetPolyline(polyline: Polyline3D)

Set the polygon points in case of a line fixture

Parameters:

  • polyline (Polyline3D) –

    Polyline of a line fixture

SetProducer

SetProducer(producer: str)

Set the producer

Parameters:

  • producer (str) –

    Producer

__init__ overloaded

__init__()

Initialize

__init__(
    fullPathName: str,
    elementType: LibraryElementType,
    placementMatrix: Matrix3D,
)

Constructor

Parameters:

  • fullPathName (str) –

    Full path and file name

  • elementType (LibraryElementType) –

    Element type

  • placementMatrix (Matrix3D) –

    Placement matrix

__init__(
    fullPathName: str,
    elementType: LibraryElementType,
    placementMatrices: Matrix3DList,
)

Constructor

Parameters:

  • fullPathName (str) –

    Full path and file name

  • elementType (LibraryElementType) –

    Element type

  • placementMatrices (Matrix3DList) –

    Placement matrices

__init__(
    path: str,
    group: str,
    element: str,
    elementType: LibraryElementType,
    placementMatrix: Matrix3D,
)

Constructor

Parameters:

  • path (str) –

    Path name

  • group (str) –

    Group name

  • element (str) –

    Element name

  • elementType (LibraryElementType) –

    Element type

  • placementMatrix (Matrix3D) –

    Placement matrix

__init__(
    path: str,
    group: str,
    element: str,
    elementType: LibraryElementType,
    placementMatrices: Matrix3DList,
)

Constructor

Parameters:

  • path (str) –

    Path name

  • group (str) –

    Group name

  • element (str) –

    Element name

  • elementType (LibraryElementType) –

    Element type

  • placementMatrices (Matrix3DList) –

    Placement matrices

__init__(
    arg2: str,
    path: str,
    group: str,
    element: str,
    elementType: LibraryElementType,
    placementMatrix: Matrix3D,
)

Constructor

Parameters:

  • path (str) –

    Path name

  • group (str) –

    Group name

  • element (str) –

    Element name

  • SingleFilePath

    SingleFilePath

  • elementType (LibraryElementType) –

    Element type

  • placementMatrix (Matrix3D) –

    Placement matrix

__init__(
    arg2: str,
    path: str,
    group: str,
    element: str,
    elementType: LibraryElementType,
    placementMatrices: Matrix3DList,
)

Constructor

Parameters:

  • path (str) –

    Path name

  • group (str) –

    Group name

  • element (str) –

    Element name

  • SingleFilePath

    SingleFilePath

  • elementType (LibraryElementType) –

    Element type

  • placementMatrices (Matrix3DList) –

    Placement matrices