Skip to content

ExtrudeBarPlacement

Canonical path: NemAll_Python_Reinforcement.ExtrudeBarPlacement

Bases: ReinfElement, AllplanElement

Implementation of the extrude bar placement element

Classes:

Methods:

Attributes:

CommonProperties property writable

CommonProperties: CommonProperties

Get the common properties

PositionNumber property writable

PositionNumber: int

Get the position number

eEdgeOffsetType

Canonical path: NemAll_Python_Reinforcement.ExtrudeBarPlacement.eEdgeOffsetType

Bases: Enum

Edge offset type

Methods:

__getitem__

__getitem__(key: str | int | float) -> eEdgeOffsetType

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

eProfileRotation

Canonical path: NemAll_Python_Reinforcement.ExtrudeBarPlacement.eProfileRotation

Bases: Enum

Profile rotation

Methods:

__getitem__

__getitem__(key: str | int | float) -> eProfileRotation

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

AddCrossBendingShape

AddCrossBendingShape(shape: BendingShape)

Add a cross bending shape

Parameters:

AddLongitudinalBarProp

AddLongitudinalBarProp(longitudinalBarProp: LongitudinalBarProperties)

Add the longitudinal bar properties

Parameters:

AddPlacementSection

AddPlacementSection(placementSection: BarPlacementSection) -> bool

Add a placement section

Parameters:

Returns:

  • bool

    Section is added: true/false

Extrude

Extrude()

Extrude the bars

GetBarOffset

GetBarOffset() -> float

Get the bar offset

Returns:

  • float

    Bar offset

GetBendingShapeViewVector

GetBendingShapeViewVector() -> Vector3D

Get the view vector of the bending shape

Returns:

  • Vector3D

    View vector of the bending shape

GetCommonProperties

GetCommonProperties() -> CommonProperties

Get the common properties

Returns:

GetConcreteCoverEnd

GetConcreteCoverEnd() -> float

Get the concrete cover at the end of the path

Returns:

  • float

    Concrete cover at the end of the path

GetConcreteCoverStart

GetConcreteCoverStart() -> float

Get the concrete cover at the start of the path

Returns:

  • float

    Concrete cover at the start of the path

GetCrossBarDistance

GetCrossBarDistance() -> float

Get the cross bar distance

Returns:

  • float

    Cross bar distance

GetCrossBendingShapes

GetCrossBendingShapes() -> BendingShapeList

Get the cross bending shapes

Returns:

GetEdgeOffsetEnd

GetEdgeOffsetEnd() -> float

Get the edge offset at the end of the path

Returns:

  • float

    Edge offset at the end of the path

GetEdgeOffsetStart

GetEdgeOffsetStart() -> float

Get the edge offset at the start of the path

Returns:

  • float

    Edge offset at the start of the path

GetEdgeOffsetType

GetEdgeOffsetType() -> eEdgeOffsetType

Get the edge offset type

Returns:

GetEdgeOffsets

GetEdgeOffsets() -> tuple

Get the edge offsets

Returns:

GetMaxBreakAngle

GetMaxBreakAngle() -> float

Get the maximal break angle

Returns:

  • float

    Maximal break angle

GetPlacementPath

GetPlacementPath() -> Path3D

Get the placement path

Returns:

GetPlacementSections

GetPlacementSections() -> object

Get the placement sections

Returns:

  • object

    Placement sections

GetPositionNumber

GetPositionNumber() -> int

Get the position number

Returns:

  • int

    Position number

GetProfileRoation

GetProfileRoation() -> eProfileRotation

Get the profile rotation

Returns:

IsBreakElimination

IsBreakElimination() -> bool

Get the break eliminination state

Returns:

  • bool

    Break elimination state

Move

Move(transVec: Vector3D)

Move the placement

Parameters:

SetCommonProperties

SetCommonProperties(commonProp: CommonProperties)

Set the common properties

Parameters:

Transform

Transform(transMat: Matrix3D)

Transform the placement

Parameters:

  • transMat (Matrix3D) –

    Transformation matrix

__init__ overloaded

__init__()

Initialize

__init__(placement: ExtrudeBarPlacement)

Copy constructor

Parameters:

__init__(
    positionNumber: int,
    path: Path3D,
    profileRotation: eProfileRotation,
    breakElimination: bool,
    maxBreakAngle: float,
    crossBarDistance: float,
    concreteCoverStart: float,
    concreteCoverEnd: float,
    edgeOffsetType: eEdgeOffsetType,
    edgeOffsetStart: float,
    edgeOffsetEnd: float,
    barOffset: float,
    bendingShapeViewVector: Vector3D,
)

Constructor for cross bars

Parameters:

  • positionNumber (int) –

    Position number

  • path (Path3D) –

    Path

  • profileRotation (eProfileRotation) –

    Profile rotation

  • breakElimination (bool) –

    Break elemination

  • maxBreakAngle (float) –

    Maximal break angle

  • crossBarDistance (float) –

    Cross bar distance

  • concreteCoverStart (float) –

    Concrete cover at the start of the path

  • concreteCoverEnd (float) –

    Concrete cover at the end of the path

  • edgeOffsetType (eEdgeOffsetType) –

    Get the edge offset type of the path

  • edgeOffsetStart (float) –

    Edge offset at the start of the path

  • edgeOffsetEnd (float) –

    Edge offset at the end of the path

  • barOffset (float) –

    Bar offset

  • bendingShapeViewVector (Vector3D) –

    View vector of the bending shape

__repr__

__repr__() -> str

Convert to string