Skip to content

QueryTypeID

Canonical path: NemAll_Python_IFW_Input.QueryTypeID

Implementation of the element type ID query

Methods:

GetQueryText

GetQueryText() -> str

Get the query text

Returns:

  • str

    Query text

GetQueryTypeID

GetQueryTypeID() -> GUID

Get the ID of the type query

Returns:

  • GUID

    ID of the type query

__call__

__call__(ele: BaseElementAdapter) -> bool

Overloaded operator ()

Parameters:

Returns:

  • bool

    Type of the element is same as the filter type: true/false

__init__ overloaded

__init__()

Initialize

__init__(typeID: GUID)

Constructor

Parameters:

  • typeID (GUID) –

    Element type ID of the filter

__init__(element: QueryTypeID)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string