Skip to content

SectionAlongPathTextParameterProperties

Canonical path: NemAll_Python_BasisElements.SectionAlongPathTextParameterProperties

Text parameter properties

Classes:

Methods:

Attributes:

  • BackgroundColorType (int) –

    Get the when =0 : no background color (transparency), when = 1 color is according to Allplan's view, when = 2, custom defined in CustomBackgroundColor

  • BorderColor (int) –

    Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

  • BorderLineType (int) –

    Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

  • BorderOffset (int) –

    Get the BorderOffset 0 it represents value -1; 4 repres. -0.5; 2 repres. 0.0; 1 repres.1.0; 5 repres. 2.0

  • BorderThickness (int) –

    Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

  • ColumnAngle (float) –

    Get the ColumnAngle

  • CustomBackgroundColor (int) –

    Get the when =0 : no background color (transparency), when = 1 color is according to Allplan's view, when = 2, custom defined in CustomBackgroundColor

  • FontAngle (float) –

    Get the FontAngle //ONLY for italic

  • FontColor (int) –

    Get the ColumnAngle

  • FontEmphasis (int) –

    Get the Font emphasis

  • FontHeight (float) –

    Get the FontHeight

  • FontID (int) –

    Get the FontType

  • FontLayer (int) –

    Get the ColumnAngle

  • FontThickness (int) –

    Get the pen of the text, never serialized, not in standard values, it is a working property only

  • FontWidth (float) –

    Get the FontWidth

  • IsFontColorFromLayer (bool) –

    Get the When False: it means scale dependent

  • IsFontLineTypeFromLayer (bool) –

    Get the When False: it means scale dependent

  • IsFontPenFromLayer (bool) –

    Get the When False: it means scale dependent

  • RowDistance (float) –

    Get the RowDistance //Line spacing

  • TextAngle (float) –

    Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

  • TextParameterID (TextPropertiesSource_Enum) –

    Initialize the class with Usable Values

  • TextParameterId (int) –

    Get the Text parameter ID

  • TextPlacementPointType (int) –

    Get the text placement point, see in NA_Data_TextDefines.h

  • UseBorderAroundTheText (bool) –

    Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

  • UseConstantSizeInLayout (bool) –

    Get the When False: it means scale dependent

BackgroundColorType property writable

BackgroundColorType: int

Get the when =0 : no background color (transparency), when = 1 color is according to Allplan's view, when = 2, custom defined in CustomBackgroundColor

BorderColor property writable

BorderColor: int

Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

BorderLineType property writable

BorderLineType: int

Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

BorderOffset property writable

BorderOffset: int

Get the BorderOffset 0 it represents value -1; 4 repres. -0.5; 2 repres. 0.0; 1 repres.1.0; 5 repres. 2.0

BorderThickness property writable

BorderThickness: int

Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

ColumnAngle property writable

ColumnAngle: float

Get the ColumnAngle

CustomBackgroundColor property writable

CustomBackgroundColor: int

Get the when =0 : no background color (transparency), when = 1 color is according to Allplan's view, when = 2, custom defined in CustomBackgroundColor

FontAngle property writable

FontAngle: float

Get the FontAngle //ONLY for italic

FontColor property writable

FontColor: int

Get the ColumnAngle

FontEmphasis property writable

FontEmphasis: int

Get the Font emphasis

FontHeight property writable

FontHeight: float

Get the FontHeight

FontID property writable

FontID: int

Get the FontType

FontLayer property writable

FontLayer: int

Get the ColumnAngle

FontThickness property writable

FontThickness: int

Get the pen of the text, never serialized, not in standard values, it is a working property only

FontWidth property writable

FontWidth: float

Get the FontWidth

IsFontColorFromLayer property writable

IsFontColorFromLayer: bool

Get the When False: it means scale dependent

IsFontLineTypeFromLayer property writable

IsFontLineTypeFromLayer: bool

Get the When False: it means scale dependent

IsFontPenFromLayer property writable

IsFontPenFromLayer: bool

Get the When False: it means scale dependent

RowDistance property writable

RowDistance: float

Get the RowDistance //Line spacing

TextAngle property writable

TextAngle: float

Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

TextParameterID property writable

TextParameterID: TextPropertiesSource_Enum

Initialize the class with Usable Values

TextParameterId property writable

TextParameterId: int

Get the Text parameter ID

TextPlacementPointType property writable

TextPlacementPointType: int

Get the text placement point, see in NA_Data_TextDefines.h

UseBorderAroundTheText property writable

UseBorderAroundTheText: bool

Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

UseConstantSizeInLayout property writable

UseConstantSizeInLayout: bool

Get the When False: it means scale dependent

TextEmphasis_Enum

Canonical path: NemAll_Python_BasisElements.SectionAlongPathTextParameterProperties.TextEmphasis_Enum

Bases: Enum

enum for Section type

eUVS_ClippingPath : Clipping line with Allplan style symbols eUVS_AdvancedStyleClippingPath: Clipping line with advanced symbols(US Standard) eUVS_USStyleHeading : Heading for sections created with advanced symbols(US Standard) eUVS_USStyleScale : Scale for sections created with advanced symbols(US Standard)

eBold : according to N_FONTSTYLE_BOLD eItalic : according to N_FONTSTYLE_ITALIC eUnderline : according to N_FONTSTYLE_UNDERLINE eStrikethrough : according to N_FONTSTYLE_STRIKETHROUGH

Methods:

__getitem__

__getitem__(key: str | int | float) -> TextEmphasis_Enum

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

TextPropertiesSource_Enum

Canonical path: NemAll_Python_BasisElements.SectionAlongPathTextParameterProperties.TextPropertiesSource_Enum

Bases: Enum

enum for Section type

eUVS_ClippingPath : Clipping line with Allplan style symbols eUVS_AdvancedStyleClippingPath: Clipping line with advanced symbols(US Standard) eUVS_USStyleHeading : Heading for sections created with advanced symbols(US Standard) eUVS_USStyleScale : Scale for sections created with advanced symbols(US Standard)

eBold : according to N_FONTSTYLE_BOLD eItalic : according to N_FONTSTYLE_ITALIC eUnderline : according to N_FONTSTYLE_UNDERLINE eStrikethrough : according to N_FONTSTYLE_STRIKETHROUGH

Methods:

__getitem__

__getitem__(key: str | int | float) -> TextPropertiesSource_Enum

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

DetectBackgroundColorType staticmethod

DetectBackgroundColorType(
    bHasBgColor: bool, bgColor: int, backgroundIsTransparent: bool
) -> tuple[int, int]

Args: bHasBgColor bgColor backgroundIsTransparent

FillPropertiesFromAllplanTextParameters

FillPropertiesFromAllplanTextParameters(
    richTextFlags: int, layerId: int, byLayerFlags: int
) -> object

Args: richTextFlags layerId byLayerFlags

__init__ overloaded

__init__()

Initialize

__init__(iTextParameterID: int, bInitFromSTW: bool = False)

constructor

Parameters:

  • iTextParameterID (int) –
    • type of text parameter
  • bInitFromSTW (bool, default: False ) –
    • is structure initialized from standard values
__init__(bInitFromSTW: bool)

constructor

Parameters:

  • bInitFromSTW (bool) –
    • is structure initialized from standard values

copy constructor