Skip to content

TangentCalculus

Canonical path: NemAll_Python_Geometry.TangentCalculus

Tangent calculation at an element point

Methods:

  • Calculate

    dummy, is only needed for the creation of the documentation by MkDocs

  • CalculateNormal

    Calculates normal vector of BRep3D at given point

Calculate overloaded

Calculate(line: Line2D) -> Vector3D

Calculates tangent vector of Line2D

Parameters:

  • line (Line2D) –

    Line2D on which to calculate tangent vector

Returns:

Calculate(line: Line3D) -> Vector3D

Calculates tangent vector of Line3D

Parameters:

  • line (Line3D) –

    line on which to calculate tangent vector

Returns:

Calculate(polyline: Polyline2D, inputPnt: Point3D) -> Vector3D

Calculates tangent vector of Polyline2D at given point

Parameters:

  • polyline (Polyline2D) –

    Polyline on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(polyline: Polyline3D, inputPnt: Point3D) -> Vector3D

Calculates tangent vector of Polyline2D at given point

Parameters:

  • polyline (Polyline3D) –

    Polyline on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(polygon: Polygon2D, inputPnt: Point3D) -> Vector3D

Calculates tangent vector of Polygon2D at given point

Parameters:

  • polygon (Polygon2D) –

    Polygon on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(arc: Arc2D, inputPnt: Point3D) -> Vector3D

Calculates tangent vector of Arc2D at given point

Parameters:

  • arc (Arc2D) –

    Arc2D on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(arc: Arc3D, inputPnt: Point3D) -> Vector3D

Calculates tangent vector of Arc3D at given point

Parameters:

  • arc (Arc3D) –

    Arc3D on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(spline: Spline2D, inputPnt: Point3D) -> Vector3D

Calculates tangent vector of Spline2D at given point

Parameters:

  • spline (Spline2D) –

    Spline on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(spline: Spline3D, inputPnt: Point3D) -> Vector3D

Calculates tangent vector of Spline2D at given point

Parameters:

  • spline (Spline3D) –

    Spline on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(bspline: BSpline2D, inputPnt: Point3D) -> Vector3D

Calculates tangent vector of BSpline2D at given point

Parameters:

  • bspline (BSpline2D) –

    BSpline on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(bspline: BSpline3D, inputPnt: Point3D) -> Vector3D

Calculates tangent vector of BSpline3D at given point

Parameters:

  • bspline (BSpline3D) –

    BSpline on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(clothoid: Clothoid2D, inputPnt: Point3D) -> Vector3D

Calculates tangent vector of Clothoid2D at given point

Parameters:

  • clothoid (Clothoid2D) –

    Clothoid on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(path: Path2D, inputPnt: Point3D) -> Vector3D

Calculates tangent vector of Path2D at given point

Parameters:

  • path (Path2D) –

    Path on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(brep: BRep3D, inputPnt: Point3D) -> Vector3DList

Calculates tangent vector of BRep3D at given point

Parameters:

  • brep (BRep3D) –

    Brep body

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

Calculate(geoObject: object, inputPnt: Point3D) -> Vector3D

Calculates tangent vector from object at given point

Parameters:

  • geoObject (object) –

    object on which to calculate tangent vector

  • inputPnt (Point3D) –

    point on object for tangent calculation

Returns:

CalculateNormal staticmethod

CalculateNormal(brep: BRep3D, inputPnt: Point3D) -> Vector3D

Calculates normal vector of BRep3D at given point

Parameters:

  • brep (BRep3D) –

    Brep body

  • inputPnt (Point3D) –

    point on object for normal calculation

Returns: