Skip to content

FixtureElement

Canonical path: NemAll_Python_Precast.FixtureElement

Bases: PrecastElement, AllplanElement

FixtureElement class

Methods:

GetFixtureProperties

GetFixtureProperties() -> FixtureProperties

Get the Fixture properties

Returns:

GetHash

GetHash() -> str

Get the hash value

Returns:

  • str

    Hash value

GetSlideList

GetSlideList() -> list

Get the slide object list

Returns:

  • list

    Slide object list

SetFixtureProperties

SetFixtureProperties(fixProp: FixtureProperties)

Set the Fixture properties

Parameters:

SetHash

SetHash(hash: str)

Set the hash value

Parameters:

  • hash (str) –

    Hash value

__init__ overloaded

__init__()

Initialize

__init__(fixProp: FixtureProperties, slideList: list)

Constructor

Parameters:

  • fixProp (FixtureProperties) –

    Fixture properties

  • slideList (list) –

    Slide list of fixture definition

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string