Skip to content

FixtureGroupProperties

Canonical path: NemAll_Python_Precast.FixtureGroupProperties

FixtureGroupProperties class

Methods:

Attributes:

  • LeadingPoint (None) –

    Leading point of the fixture group

  • Name (None) –

    Name of the fixture group

  • Type (None) –

    Type of the fixture group

LeadingPoint property

LeadingPoint: None

Leading point of the fixture group

Value type: Point3D

:type: None

Name property

Name: None

Name of the fixture group

Value type: str

:type: None

Type property

Type: None

Type of the fixture group (General|Dynamic|Cutted|Leading) Value type: enum

:type: None

__eq__

__eq__(prop: FixtureGroupProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string