Skip to content

SweepBarPlacement

Canonical path: NemAll_Python_Reinforcement.SweepBarPlacement

Bases: ReinfElement, AllplanElement

Implementation of the sweep bar placement element

Classes:

Methods:

Attributes:

CommonProperties property writable

CommonProperties: CommonProperties

Get the common properties

PositionNumber property writable

PositionNumber: int

Get the position number

eEdgeOffsetType

Canonical path: NemAll_Python_Reinforcement.SweepBarPlacement.eEdgeOffsetType

Bases: Enum

Edge offset types

Methods:

__getitem__

__getitem__(key: str | int | float) -> eEdgeOffsetType

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

AddPlacementSection

AddPlacementSection(placementSection: BarPlacementSection) -> bool

Add a placement section

Parameters:

Returns:

  • bool

    Section is added: true/false

AddSectionBars

AddSectionBars(
    bendingShapes: BendingShapeList,
    sectionsLongitudinalBarsProp: LongitudinalBarPropertiesList,
    sectionPlane: Plane3D,
)

Add the bars and the section plane for a section

bendingShapeViewVector View vector of the bending shape

Parameters:

GetBarOffset

GetBarOffset() -> float

Get the bar offset

Returns:

  • float

    Bar offset

GetBenchingAngle

GetBenchingAngle() -> float

Get the benching angle

Returns:

  • float

    Benching angle

GetBenchingLength

GetBenchingLength() -> float

Get the benching length

Returns:

  • float

    Benching length

GetCommonProperties

GetCommonProperties() -> CommonProperties

Get the common properties

Returns:

GetConcreteCoverEnd

GetConcreteCoverEnd() -> float

Get the concrete cover at the end of the path

Returns:

  • float

    Concrete cover at the end of the path

GetConcreteCoverStart

GetConcreteCoverStart() -> float

Get the concrete cover at the start of the path

Returns:

  • float

    Concrete cover at the start of the path

GetCrossBarDistance

GetCrossBarDistance() -> float

Get the cross bar distance

Returns:

  • float

    Cross bar distance

GetEdgeOffsetEnd

GetEdgeOffsetEnd() -> float

Get the edge offset at the end of the path

Returns:

  • float

    Edge offset at the end of the path

GetEdgeOffsetStart

GetEdgeOffsetStart() -> float

Get the edge offset at the start of the path

Returns:

  • float

    Edge offset at the start of the path

GetEdgeOffsetType

GetEdgeOffsetType() -> eEdgeOffsetType

Get the edge offset type

Returns:

GetEdgeOffsets

GetEdgeOffsets() -> tuple

Get the edge offsets

Returns:

GetPlacementSections

GetPlacementSections() -> object

Get the placement sections

Returns:

  • object

    Placement sections

GetPositionNumber

GetPositionNumber() -> int

Get the position number

Returns:

  • int

    Position number

IsFirstPathIsSweepPath

IsFirstPathIsSweepPath() -> bool

Get the first path is sweep path state

Returns:

  • bool

    First path is sweep path state

IsInterpolation

IsInterpolation() -> bool

Get the interpolation state

Returns:

  • bool

    Interpolation state

IsInterpolationOfAllPoints

IsInterpolationOfAllPoints() -> bool

Get the interpolation of all points state

Returns:

  • bool

    Interpolation of all points state

IsRoation

IsRoation() -> bool

Get the rotation state

Returns:

  • bool

    Rotation state

Move

Move(transVec: Vector3D)

Move the placement

Parameters:

SetCommonProperties

SetCommonProperties(commonProp: CommonProperties)

Set the common properties

Parameters:

SetPositionNumber

SetPositionNumber(positionNumber: int)

Set the position number

Parameters:

  • positionNumber (int) –

    Position number

Sweep

Sweep()

Sweep the bars

Transform

Transform(transMat: Matrix3D)

Transform the placement

Parameters:

  • transMat (Matrix3D) –

    Transformation matrix

__init__ overloaded

__init__()

Initialize

__init__(placement: SweepBarPlacement)

Copy constructor

Parameters:

__init__(
    positionNumber: int,
    sweepPaths: Path3DList,
    rotation: bool,
    firstPathIsSweepPath: bool,
    interpolation: bool,
    interpolationOfAllPoints: bool,
    crossBarDistance: float,
    concreteCoverStart: float,
    concreteCoverEnd: float,
    edgeOffsetType: eEdgeOffsetType,
    edgeOffsetStart: float,
    edgeOffsetEnd: float,
    barOffset: float,
    benchingLength: float,
    benchingAngle: float,
)

Constructor for cross bars

Parameters:

  • positionNumber (int) –

    Position number

  • sweepPaths (Path3DList) –

    Path

  • rotation (bool) –

    Rotation

  • firstPathIsSweepPath (bool) –

    First path is also sweep path

  • interpolation (bool) –

    Interpolation

  • interpolationOfAllPoints (bool) –

    Interpolation of all points

  • crossBarDistance (float) –

    Cross bar distance

  • concreteCoverStart (float) –

    Concrete cover at the start of the path

  • concreteCoverEnd (float) –

    Concrete cover at the end of the path

  • edgeOffsetType (eEdgeOffsetType) –

    Get the edge offset type of the path

  • edgeOffsetStart (float) –

    Edge offset at the start of the path

  • edgeOffsetEnd (float) –

    Edge offset at the end of the path

  • barOffset (float) –

    Bar offset

  • benchingLength (float) –

    Benching length

  • benchingAngle (float) –

    Benching angle

__repr__

__repr__() -> str

Convert to string