Skip to content

MacroSlideElement

Canonical path: NemAll_Python_BasisElements.MacroSlideElement

Bases: BasisElement, AllplanElement

Representation of a macro slide. In Allplan referred to as foil of a smart symbol

Methods:

GetMacroSlideProperties

GetMacroSlideProperties() -> MacroSlideProperties

Get the MacroSlide properties

Returns:

GetObjectList

GetObjectList() -> list

Get the slide object list

Returns:

  • list

    Slide object list

SetMacroSlideProperties

SetMacroSlideProperties(MacroSlideProp: MacroSlideProperties)

Set the MacroSlide properties

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(macroSlideProp: MacroSlideProperties, objectList: list)

Constructor

Parameters:

  • macroSlideProp (MacroSlideProperties) –

    MacroSlide properties

  • objectList (list) –

    Object list of slide

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string