Skip to content

eAngleGradientUnit

Canonical path: NemAll_Python_AllplanSettings.eAngleGradientUnit

Bases: Enum

Enumeration of available angle units for input of rotation and inclination

Attributes:

ANGLE_DEGREE class-attribute instance-attribute

ANGLE_DEGREE = 1

Degrees

ANGLE_GON class-attribute instance-attribute

ANGLE_GON = 3

Gradians

ANGLE_NOTDEF class-attribute instance-attribute

ANGLE_NOTDEF = 0

Undefined

ANGLE_PERCENT class-attribute instance-attribute

ANGLE_PERCENT = 5

Inclination as %

ANGLE_PERCENTAGE class-attribute instance-attribute

ANGLE_PERCENTAGE = 4

Inclination as 1:x

ANGLE_PERMILL class-attribute instance-attribute

ANGLE_PERMILL = 6

Inclination as ‰

ANGLE_RADIAN class-attribute instance-attribute

ANGLE_RADIAN = 2

Radians