Skip to content

BarPlacementSection

Canonical path: NemAll_Python_Reinforcement.BarPlacementSection

Implementation of the bar placement section class

Methods:

GetDistance

GetDistance() -> float

Get the distance

Returns:

  • float

    Distance

GetLength

GetLength() -> float

Get the length

Returns:

  • float

    Length

IsEnabled

IsEnabled() -> bool

Get the enabled state

Returns:

  • bool

    Enable state

__init__ overloaded

__init__(isEnabled: bool, length: float, distance: float)

Constructor

Parameters:

  • isEnabled (bool) –

    Section enabled state

  • length (float) –

    Section length

  • distance (float) –

    Bar distance

__init__(element: BarPlacementSection)

Copy constructor

Parameters: