Skip to content

AssemblyGroupElement

Canonical path: NemAll_Python_Precast.AssemblyGroupElement

Bases: PrecastElement, AllplanElement

AssemblyGroupElement class

Methods:

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert to string

Attributes:

  • FixtureElementsList (None) –

    List of parametric fixtures which should be included in the assembly group

  • LibraryElementsList (None) –

    List of library fixtures which should be included in the assembly group

  • Name (None) –

    Name of the assembly group

  • Number (None) –

    Number of the assembly group

  • ReinforcementList (None) –

    List of reinforcement placements which should be included in the assembly group

FixtureElementsList property

FixtureElementsList: None

List of parametric fixtures which should be included in the assembly group Value type: list

:type: None

LibraryElementsList property

LibraryElementsList: None

List of library fixtures which should be included in the assembly group Value type: list

:type: None

Name property

Name: None

Name of the assembly group Value type: str

:type: None

Number property

Number: None

Number of the assembly group Value type: int

:type: None

ReinforcementList property

ReinforcementList: None

List of reinforcement placements which should be included in the assembly group Value type: list

:type: None

__init__ overloaded

__init__()

Initialize

__init__(
    name: str,
    number: int,
    LibraryElementsList: list,
    FixtureElementsList: list,
    ReinforcementList: list,
)

Constructor

Parameters:

  • name (str) –

    Name of the assembly group

  • number (int) –

    Number of the assembly group

  • LibraryElementsList (list) –

    List of library fixtures which should be included in the assembly group

  • FixtureElementsList (list) –

    List of parametric fixtures which should be included in the assembly group

  • ReinforcementList (list) –

    List of reinforcement placements which should be included in the assembly group

__repr__

__repr__() -> str

Convert to string