Skip to content

AllplanVersion

Canonical path: NemAll_Python_AllplanSettings.AllplanVersion

Class for extraction of Allplan version information

Methods:

MainReleaseName staticmethod

MainReleaseName() -> str

Get the Allplan main release name Returns: Allplan main release name ('2016', '2017', ...)

SubReleaseName staticmethod

SubReleaseName() -> str

Get the Allplan sub release name Returns: Allplan sub release name ('2016.0', '2016.1', ...)

Version staticmethod

Version() -> str

Get the Allplan version as string

Returns:

  • str

    Allplan version

Examples:

>>> AllplanVersion.Version()
2023.1

WindowsReleaseName staticmethod

WindowsReleaseName() -> str

Get the Allplan window release name Returns: 'P' for project version or empty string for the normal version