Skip to content

RefPointButtonType

Canonical path: NemAll_Python_Palette.RefPointButtonType

Bases: Enum

Definition of available positions of the reference point on a reference point button.

Attributes:

  • eAllNinePositions

    All nine positions of the reference point are available.

  • eAllTenPositions

    All nine positions of the reference point are available, plus tenth option. of an undefined point.

  • eCorners

    Only four positions in the corners possible.

  • eCornersCenter

    Five positions possible. Four in the corners plus in the center.

  • eLeftRightCenter

    Three positions possible. Center-left, center-center and center-right.

  • eNoCorners

    Five positions possible. In the middle and on the center of each edge.

  • eTopBottomCenter

    Three positions possible. Top-center, center-center and bottom-center.

eAllNinePositions class-attribute instance-attribute

eAllNinePositions = 0

All nine positions of the reference point are available.

eAllTenPositions class-attribute instance-attribute

eAllTenPositions = 6

All nine positions of the reference point are available, plus tenth option. of an undefined point.

eCorners class-attribute instance-attribute

eCorners = 2

Only four positions in the corners possible.

eCornersCenter class-attribute instance-attribute

eCornersCenter = 3

Five positions possible. Four in the corners plus in the center.

eLeftRightCenter class-attribute instance-attribute

eLeftRightCenter = 4

Three positions possible. Center-left, center-center and center-right.

eNoCorners class-attribute instance-attribute

eNoCorners = 1

Five positions possible. In the middle and on the center of each edge.

eTopBottomCenter class-attribute instance-attribute

eTopBottomCenter = 5

Three positions possible. Top-center, center-center and bottom-center.