Skip to content

AnchorageLengthService

Canonical path: NemAll_Python_Reinforcement.AnchorageLengthService

Service class for the anchorage length calculation

Methods:

Calculate

Calculate(
    concreteGrade: int,
    steelGrade: int,
    diameter: float,
    asMesh: float,
    bDoubleBar: bool,
    meshBarDistCross: float,
    bMesh: bool,
    barDistance: float,
    roundLength: float,
)

Calculation of the anchorage length

Parameters:

  • concreteGrade (int) –

    Concrete grade index (starting from 1)

  • steelGrade (int) –

    Steel grade

  • diameter (float) –

    Diameter

  • asMesh (float) –

    asMesh of the mesh

  • bDoubleBar (bool) –

    Double bar

  • meshBarDistCross (float) –

    Distance of the mesh bars cross to the anchorage direction

  • bMesh (bool) –

    Anchorage for a mesh

  • barDistance (float) –

    Bar distance

  • roundLength (float) –

    Rounding length

CalculateBar

CalculateBar(
    concreteGrade: int,
    steelGrade: int,
    diameter: float,
    bDoubleBar: bool,
    barDistance: float,
    roundLength: float,
)

Calculation of the anchorage length for a bar

Parameters:

  • concreteGrade (int) –

    Concrete grade index (starting from 1)

  • steelGrade (int) –

    Steel grade

  • diameter (float) –

    Diameter

  • bDoubleBar (bool) –

    Double bar

  • barDistance (float) –

    Bar distance

  • roundLength (float) –

    Rounding length

GetAnchorageLength

GetAnchorageLength() -> float

Get the anchorage length

Returns:

  • float

    Anchorage length

GetAnchorageType

GetAnchorageType() -> AnchorageType

Get the anchorage type

Returns:

GetAsFactor

GetAsFactor() -> float

Get the as factor required / available

Returns:

  • float

    As mesh factor

GetCompositionZone

GetCompositionZone() -> int

Get the composition zone

Returns:

  • int

    Composition zone

GetHookAngle

GetHookAngle() -> float

Get the hook angle

Returns:

  • float

    Hook angle

GetL1

GetL1() -> float

Get length L1

Returns:

  • float

    Length L1

GetL2

GetL2() -> float

Get length L2

Returns:

  • float

    Length L2

GetL3

GetL3() -> float

Get length L3

Returns:

  • float

    Length L3

GetLongitudinalOffset

GetLongitudinalOffset() -> float

Get the longitudinal offset

Returns:

  • float

    Longitudinal offset

GetOverlapLength

GetOverlapLength() -> float

Get the overlap length

Returns:

  • float

    Overlap length

IsCompressionBar

IsCompressionBar() -> bool

Get the compression bar state

Returns:

  • bool

    Compression bar: true/false

SetAnchorageType

SetAnchorageType(anchorageType: AnchorageType)

Set the anchorage type

Parameters:

SetAsFactor

SetAsFactor(AsFactor: float)

Set the as factor required / available

Parameters:

  • AsFactor (float) –

    As facto required / availabler

SetCompositionZone

SetCompositionZone(compositionZone: int)

Set the composition zone

Parameters:

  • compositionZone (int) –

    Composition zone

SetCompressionBar

SetCompressionBar(bCompressionBar: bool)

Set the compression bar state

Parameters:

  • bCompressionBar (bool) –

    Compression bar: true/false

SetHookAngle

SetHookAngle(hookAngle: float)

Set the hook angle

Parameters:

  • hookAngle (float) –

    Hook angle

SetLongitudinalOffset

SetLongitudinalOffset(longitudinalOffset: float)

Set the longitudinal offset

Parameters:

  • longitudinalOffset (float) –

    longitudinal offset

__init__

__init__()

Initialize