Skip to content

BarPositionData

Canonical path: NemAll_Python_Reinforcement.BarPositionData

Implementation of the bar position data

Methods:

Attributes:

  • Count (int) –

    Get the count

  • Diameter (float) –

    Get the diameter

  • Length (float) –

    Get the length

  • Position (int) –

    Get the position number

  • SteelGrade (int) –

    Get the steel grade

Count property writable

Count: int

Get the count

Diameter property writable

Diameter: float

Get the diameter

Length property writable

Length: float

Get the length

Position property writable

Position: int

Get the position number

SteelGrade property writable

SteelGrade: int

Get the steel grade

GetCount

GetCount() -> int

Get the count

Returns:

  • int

    Count

GetDiameter

GetDiameter() -> float

Get the diameter

Returns:

  • float

    diameter

GetLength

GetLength() -> float

Get the length

Returns:

  • float

    length

GetPosition

GetPosition() -> int

Get the position number

Returns:

  • int

    Position number

GetSteelGrade

GetSteelGrade() -> int

Get the steel grade

Returns:

  • int

    Steel grade

SetCount

SetCount(count: int)

Set the count

Parameters:

  • count (int) –

    Count

SetDiameter

SetDiameter(diameter: float)

Set the diameter

Parameters:

  • diameter (float) –

    diameter

SetLength

SetLength(length: float)

Set the length

Parameters:

  • length (float) –

    length

SetPosition

SetPosition(position: int)

Set the position number

Parameters:

  • position (int) –

    Position

SetSteelGrade

SetSteelGrade(steelGrade: int)

Set the steel grade

Parameters:

  • steelGrade (int) –

    steel grade

__init__

__init__(element: BarPositionData)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string