Skip to content

ReferencePlaneID

Canonical path: NemAll_Python_ArchElements.ReferencePlaneID

struct for handling reference plane IDs

Methods:

Attributes:

ModelGuid property writable

ModelGuid: GUID

Get model

change model id to another

PlaneId property

PlaneId: int

Get plane ID

Invalidate

Invalidate()

Set values to undefined state

IsDefaultLowerPlane

IsDefaultLowerPlane() -> bool

Find out if reference plane is default lower reference plane

Returns:

  • bool

    true if ref plane is default lower ref plane

IsDefaultUpperPlane

IsDefaultUpperPlane() -> bool

Find out if reference plane is default upper reference plane

Returns:

  • bool

    true if ref plane is default upper ref plane

IsDocumentRefSurface

IsDocumentRefSurface() -> bool

Find out if reference surface is from document

Returns:

  • bool

    true is reference surface from document (not in model)

IsInModel

IsInModel() -> bool

Find out if reference plane is in model

Returns:

  • bool

    true if ref plane is in model

IsValid

IsValid() -> bool

Get validity of ref plane

Returns:

  • bool

    true if ref plane is valid

SetCustomLowerPlane

SetCustomLowerPlane()

Set values to custom lower state

SetCustomUpperPlane

SetCustomUpperPlane()

Set values to custom upper state

__eq__

__eq__(other: ReferencePlaneID) -> bool

Equal operator

Parameters:

Returns:

  • bool

    Reference plane IDs are equal

__init__ overloaded

__init__()

Initialize

__init__(modelGuid: GUID, planeId: int)

Constructor

Parameters:

  • modelGuid (GUID) –

    Model guid

  • planeId (int) –

    Plane ID

__init__(element: ReferencePlaneID)

Copy constructor

Parameters:

__lt__

__lt__(other: ReferencePlaneID) -> bool

Less operator

Parameters:

Returns:

  • bool

    Reference plane is lees then other

__ne__

__ne__(other: ReferencePlaneID) -> bool

Unequal operator

Parameters:

Returns:

  • bool

    Reference plane IDs are not equal

__repr__

__repr__() -> str

Convert to string