Skip to content

OrientedEdge

Canonical path: NemAll_Python_Geometry.OrientedEdge

Oriented edge Identification of any edge via edge handle and orientation (positive, negative).

Methods:

Attributes:

  • EdgeHandle (None) –

    Get and set the edge handle property

  • Positive (None) –

    Get and set the positive orientation property

EdgeHandle property

EdgeHandle: None

Get and set the edge handle property

:type: None

Positive property

Positive: None

Get and set the positive orientation property

:type: None

GetEdgeHandle

GetEdgeHandle() -> int

Get handle to the edge

Returns:

  • int

    Edge handle.

HasPositiveOrientation

HasPositiveOrientation() -> bool

Get the flag of positive orientation.

Returns:

  • bool

    True when edge have positive orientation, otherwise false.

Set overloaded

Set(orientedEdge: OrientedEdge)

Initialize edge from old Allplan structure

Parameters:

  • orientedEdge (OrientedEdge) –

    Edge which will be copied.

Set(edgeHandle: int, positiveOrientation: bool)

Set edge handle and orientation

Handle is not checked, you set anything.

Parameters:

  • edgeHandle (int) –

    Handle to the edge which will be set.

  • positiveOrientation (bool) –

    Set true when orientation is positive, otherwise false.

SetEdgeHandle

SetEdgeHandle(edgeHandle: int)

Set handle to the edge

edgeHandle is not checked, you set anything.

Parameters:

  • edgeHandle (int) –

    Handle to the edge which will be set.

SetOrientation

SetOrientation(positiveOrientation: bool)

Set orientation

Parameters:

  • positiveOrientation (bool) –

    Set true when orientation is positive, otherwise false.

__eq__

__eq__(orientedEdge: OrientedEdge) -> object

Equal operator

Parameters:

Returns:

  • object

    True when both edges are equal.

__init__ overloaded

__init__()

Initialize

__init__(edgeHandle: int, positiveOrientation: bool)

Constructor

Parameters:

  • edgeHandle (int) –

    Set edge handle.

  • positiveOrientation (bool) –

    Set orientation, true for positive, false for negative

__init__(orientedEdge: OrientedEdge)

Copy constructor

Parameters:

  • orientedEdge (OrientedEdge) –

    Edge which will be copied.

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string