Skip to content

StructuralElementProperties

Canonical path: NemAll_Python_ArchElements.StructuralElementProperties

Bases: ArchBaseProperties

Representation of the properties of structural framing element

Methods:

Attributes:

DoubleProfileGap property writable

DoubleProfileGap: float

Gets double profile gap

EndPointZOffset property writable

EndPointZOffset: float

Get the value of Z offset of the anchor point at end the point of SF element

ProfileAngle property writable

ProfileAngle: Angle

Get the rotation angle of element profile

ProfileShapeProperties property writable

ProfileShapeProperties: object

Get ProfileShapeProperties

ShapeTypeAtEnd property writable

Get truncation type at the start of the Structural Element

ShapeTypeAtStart property writable

ShapeTypeAtStart: SolidElementTruncationType

Get truncation type at the end of the Structural Element

StartPointZOffset property writable

StartPointZOffset: float

Get the value of Z offset of the anchor point at start the point of SF element

AddHole

AddHole(holeGeometry: BRep3D) -> int

Adds a hole to the list of holes for the Structural Element

Parameters:

  • holeGeometry (BRep3D) –

    3D BRep Geometry of the hole

Returns:

  • int

    Unique ID for the created hole

GetAnglesAtEnd

GetAnglesAtEnd() -> tuple

Get angles between the cross-sectional area and the plane perpendicular to the axis of the structural framing element at its end

Returns:

  • tuple

    angle in local X direction

  • tuple

    angle in local Y direction

GetAnglesAtStart

GetAnglesAtStart() -> tuple

Get angles between the cross-sectional area and the plane perpendicular to the axis of the structural framing element at its start

Returns:

  • tuple

    angle in local X direction

  • tuple

    angle in local Y direction

GetBodyAxis

GetBodyAxis() -> Line3D

Get the Axis of the structural framing element calculated in the cross section's center of gravity

Returns:

GetCenterAxis

GetCenterAxis() -> Line3D

Get the axis of the structural framing element calculated in the center of the cross section outline

Returns:

GetDoubleProfileGap

GetDoubleProfileGap() -> float

Gets double profile gap

Returns:

  • float

    Double profile gap

GetEndPointAdditionalOffset

GetEndPointAdditionalOffset() -> Vector3D

Get the end point distance dx/dy

Returns:

  • Vector3D

    Vector3D with offsets in x and y like Vector3D(distance_dx, distance dy, 0)

GetEndPointZOffset

GetEndPointZOffset() -> float

Get the the offset between the anchor end point and the element end point of a structural framing element

Returns:

  • float

    Offset value

GetEndReferencePointType

GetEndReferencePointType() -> CustomBoxPoint

Get type the reference point at end

Returns:

GetHeightProperties

GetHeightProperties() -> PlaneReferences

Get HeightProperties

Returns:

GetHoles

GetHoles() -> dict

Returns existing holes as python dictionary, where key is hole ID, value is its geometry

Returns:

  • dict

    Existing holes as python dictionary, where key is hole ID, value is its geometry

GetProfileAngle

GetProfileAngle() -> Angle

Get rotation angle of cross section profile around the axis of a structural framing element

Returns:

  • Angle

    Rotation angle

GetProfileShapeProperties

GetProfileShapeProperties() -> object

Get the shape properties of the cross section

Returns:

  • object

    Cross section properties

GetShapeTypeAtEnd

GetShapeTypeAtEnd() -> SolidElementTruncationType

Get truncation type at the element's end point

Returns:

GetShapeTypeAtStart

GetShapeTypeAtStart() -> SolidElementTruncationType

Get truncation type at the element's start point

Returns:

GetSkeletonSolidElementProperties

GetSkeletonSolidElementProperties() -> object

Get SkeletonSolidElementProperties

Returns:

  • object

    SkeletonSolidElementProperties

GetStartPointAdditionalOffset

GetStartPointAdditionalOffset() -> Vector3D

Get the start point distance dx/dy

Returns:

  • Vector3D

    Vector3D with offsets in x and y like Vector3D(distance_dx, distance dy, 0)

GetStartPointZOffset

GetStartPointZOffset() -> float

Get the the offset between the anchor start point and the element start point of a structural framing element

Returns:

  • float

    Offset value

GetStartReferencePointType

GetStartReferencePointType() -> CustomBoxPoint

Get type of the reference point at start

Returns:

GetZCoordsVisibility

GetZCoordsVisibility() -> bool

Get visibility of Z coordinates of insertion point

Returns:

  • bool

    True if Z coordinates visible, False otherwise

HasTwoAnchorPoints

HasTwoAnchorPoints() -> bool

Get the two anchor point state

Returns:

  • bool

    Two anchor point state

RemoveHole

RemoveHole(holeID: int)

Removes a hole to the list of holes for the Structural Element

Parameters:

  • holeID (int) –

    ID of the hole to remove. This ID is obtained by AddHole operation

SetAnglesAtEnd

SetAnglesAtEnd(angleX: Angle, angleY: Angle)

Set angles between the cross-sectional area and the plane perpendicular to the axis of the structural framing element at its end

Parameters:

  • angleX (Angle) –

    angle in local X direction

  • angleY (Angle) –

    angle in local Y direction

SetAnglesAtStart

SetAnglesAtStart(angleX: Angle, angleY: Angle)

Set angles between the cross-sectional area and the plane perpendicular to the axis of the structural framing element at its start

Parameters:

  • angleX (Angle) –

    angle in local X direction

  • angleY (Angle) –

    angle in local Y direction

SetAttribute

SetAttribute(attrib: object)

Set the attribute

Parameters:

  • attrib (object) –

    Attribute

SetCommonProperties

SetCommonProperties(comProp: CommonProperties)

Set the Common properties

Parameters:

SetDoubleProfileGap

SetDoubleProfileGap(desiredGap: float) -> bool

Set the gap of double profile

Parameters:

  • desiredGap (float) –

    Desired gap

Returns:

  • bool

    true if attribute Gap was correctly set and exists / false if given profile doesn't have attribute Gap

SetEndPointZOffset

SetEndPointZOffset(desiredOffset: float)

Set the offset between the anchor end point and the element end point of a structural framing element

Parameters:

  • desiredOffset (float) –

    offset value

SetProfileAngle

SetProfileAngle(value: Angle)

Set rotation angle of cross section profile around the axis of a structural framing element

Parameters:

  • value (Angle) –

    Rotation angle

SetProfileShapeProperties

SetProfileShapeProperties(value: object)

Set cross-section shape properties

Parameters:

  • value (object) –

    Profile Shape Properties\n

SetShapeTypeAtEnd

SetShapeTypeAtEnd(endTruncationType: SolidElementTruncationType)

Set truncation type at the element's end point

Parameters:

SetShapeTypeAtStart

SetShapeTypeAtStart(startTruncationType: SolidElementTruncationType)

Set truncation type at the element's start point

Parameters:

SetStartPointZOffset

SetStartPointZOffset(desiredOffset: float)

Set the offset between the anchor start point and the element start point of a structural framing element

Parameters:

  • desiredOffset (float) –

    offset value

SetTwoAnchorPoints

SetTwoAnchorPoints(areTwoAnchorPoint: bool)

Whether the structural framing element should have two different anchor points at beginning and at end

Parameters:

  • areTwoAnchorPoint (bool) –

    True to make the element have two different anchor points, False otherwise

__init__ overloaded

__init__()

Initialize

__init__(value: StructuralElementProperties)

Constructor

Parameters: